Results 1 to 3 of 3
Discuss 3GS white screening at the iPhone 3GS - Hackint0sh.org; Hi there, I fixed a 3GS (digitizer replacement) and it was working fine.(worked fine for ...
  1. #1
    Newbie Array

    Join Date
    Jun 2011
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default 3GS white screening

    Hi there,

    I fixed a 3GS (digitizer replacement) and it was working fine.(worked fine for 2+ days)

    2 days later and now its white screening? Tried the hard reset (home+lock) but still nothing.

    What can anyone suggest?

    Help would be appreciated massively!



  2. #2
    Professional Array

    Join Date
    Jan 2009
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    8

    Default

    From what I understand, it seems as if something happened to the LCD ribbon connector mid-repair. Replacing your LCD screen may help, unless you've tried to use the LCD with a different digitizer setup and it worked.

  3. #3
    Professional Array

    Join Date
    Dec 2009
    Posts
    98
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Default

    I have replaced a few digitizers. Open your phone back up and make sure your all your connectors are still connected, especially #3. It can be hard to attach back sometimes. If not you might have bought a bad part. Also its good to look over your LCD to make sure there aren't any blemishes. They can look like lines or an off color spots. If that is the case you'll need to replace it, which is simple.

 

 

Similar Threads

  1. Replies: 0
    Last Post: 07-12-2011, 06:20 AM
  2. Replies: 0
    Last Post: 04-09-2011, 12:20 AM
  3. MacNN: Apple's App Store API screening flawed, says developer
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 11-20-2009, 11:00 PM
  4. Apple: Screening at the 2009 Tribeca Film Festival
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 04-24-2009, 07:40 PM
  5. G5 Blue Screening on Boot
    By lcortex in forum Archiv (Leopard)
    Replies: 0
    Last Post: 06-07-2007, 05:02 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:55 AM.
twitter, follow us!