Results 1 to 6 of 6
Discuss 3GS can enter DFU but then drops USB connection while "preparing iPhone to restore" at the iPhone 3GS - Hackint0sh.org; Hello - I'm at my wit's end (common I'm sure) with this 3GS. I am ...
  1. #1
    Newbie Array

    Join Date
    Mar 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question [FIXED]3GS can enter DFU but then drops USB connection

    Hello - I'm at my wit's end (common I'm sure) with this 3GS. I am not trying to jailbreak, just restore to factory functionality after the phone locked up.

    The phone will not enter Recovery mode at all, and in order to communicate with it I have to put it in DFU mode.

    When I do, iTunes will see it and tell me to restore. I say OK.

    Once iTunes gets to the point where it is "preparing iPhone for restore," the phone will lose its USB connection (dong sound) and never regain it.

    Here is, hopefully, a copy of my iPhone updater log file: 2012-03-21 15:48:15.485 [2572:2308]: restore library built Feb 6 2012 at 17:46: - Pastebin.com

    Any advice would be appreciated.

    Thank you for reading.
    Last edited by mikeflstfi; 03-23-2012 at 01:04 AM.



  2. #2
    Advanced Array

    Join Date
    Jul 2010
    Posts
    49
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

  3. #3
    Newbie Array

    Join Date
    Mar 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by aneagle View Post
    Thank you for your response. I have seen that article and tried the solution listed three times, on two different computers, with two different 30-pin Apple USB connectors. The result is the same.

    Any other ideas from anyone?

  4. #4
    Newbie Array

    Join Date
    Mar 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Well, it's fixed. But in a good news/bad news sort of way.

    I decided that it had to be hardware related, maybe something in the USB connector (thanks to n1ckn4m3 for the suggestion) and I disassembled the iPhone.

    I took out the daughterboard for the USB connector and cleaned it with some Deox-IT and then re-installed it, making sure everything was tight.

    I had also removed the motherboard, thinking that it could be related a loose connector or something. When re-assembling the motherboard, I damaged the ribbon cable connecting the camera to the motherboard. Sheist.

    I went ahead and finished putting it back together and plugged it into the computer. After about 20 minutes of charging, it came up in Recovery mode. Restored to 5.0.1 with no problem, and restored from iTunes backup.

    Net: My wife has a working phone again, but with no camera.

    Does anyone know if replacing that ribbon cable is possible? Or maybe the camera assembly?

  5. Like n1ckn4m3 liked this post.
  6. #5
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    I think you want this:

    Replacement Camera Lens FPC Connector Flex Ribbon Cable for iPhone 3G IPF38X - $1.93 - Affordable Parts & Repair

    or this:

    Cet iPhone 3GS Compatible Replacement Camera Module Assembly (20032206) - iPhone, Cell Phones, Electronics & Computers - nuLime.com

    One of the two should fix your issue. Been a while since I broke open a 3GS so I can't remember directly whether the top piece alone would do it for you.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!



  7. #6
    Newbie Array

    Join Date
    Mar 2012
    Posts
    4
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks. I ordered the CET replacement. We'll see how that goes. Appreciate the help!

 

 

Similar Threads

  1. Replies: 0
    Last Post: 12-27-2011, 03:40 PM
  2. Replies: 8
    Last Post: 07-11-2009, 10:00 AM
  3. SSH terminate after pressing "enter"
    By copo in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 10-22-2007, 06:53 PM
  4. Replies: 0
    Last Post: 10-06-2007, 07:00 PM
  5. Replies: 0
    Last Post: 09-12-2007, 01:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:26 AM.
twitter, follow us!