Results 1 to 4 of 4
Discuss SpiritJB failed on my iphone 3g/3.1.3/5.12.01 - recommendations on jailbreak please at the iPhone 3G - Hackint0sh.org; I recently purchased an iphone 3g 8gb ATT phone. It is running iOS version 3.1.3 ...
  1. #1
    Newbie Array

    Join Date
    Jan 2012
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default SpiritJB failed on my iphone 3g/3.1.3/5.12.01 - recommendations on jailbreak please

    I recently purchased an iphone 3g 8gb ATT phone. It is running iOS version 3.1.3 with baseband 5.12.01

    I want to unlock the phone for use with Tmobile, so I began by trying to jailbreak after which I plan to run ultrasn0w to complete the unlock. Unfortunately I have tried Spirit and have been unsuccessful. I run as administrator with the win98 compatibility and get the screen saying that spirit is ready and detects my phone running 3.1.3 It then goes through the process and says that it was successful and I see the rainbow picture on the phone screen. However no cydia appears. Any thoughts on this? I can only think that maybe the iTunes version I am using is not correct (10.5.2) since all the posts I find mention 9.1, but I did not get any error messages and from what I can see spirit never opens iTunes either. Let me know if I need to downgrade this or something.

    As a backup plan I was going to use the latest redsn0w. The phone is already on stock 3.1.3 but when I loaded up redsn0w it asked me to point it to the firmware version as it could not autodetect, so I pointed it to stock 3.1.3 and it said that it was not supported. Upon digging I think that I need to point it to the 3.1.2 version of the ipsw but I just wanted to confirm before I do that and screw up the phone by using the wrong file.

    Also please feel free to suggest an alternate method if I missed something.

    Thanks so much, and happy new year!



  2. #2
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Easiest method would be to restore to iOS 4.2.1, blocking the baseband update if you choose, then jailbreaking and unlocking 4.2.1. Tools for 3.1.x are hard to find these days, but do still work if you can find them. Unless you're actively avoiding iOS 4, this is what I recommend. You'd need redsn0w 0.9.6b7 for the jailbreak, and PwnageTool 4.2 to create the .IPSW without baseband. Download the 4.2.1 .IPSW from iClarified or from Apple directly, don't download pre-custom/pre-jailbroken firmware.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  3. #3
    Newbie Array

    Join Date
    Jan 2012
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks for the reply. I actually am avoiding version 4.x as it runs so slowly on the 3g model I have.

    As I understood it, spirit should have worked on 3.1.3 but Im not finding that it does even though it seems to go through all the steps it is supposed to without an error message.

    I was going to use redsn0w (the current version) with ispw 3.1.2. Do you know if that is the method I should be using to accomplish the jailbreak? The unlock is simple once Im jailbroken...

  4. #4
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Fair enough on avoiding 4.x, though as I recall, 4.2 was much better than 4.0, but to each their own! There's no reason I'm aware of that would require you to upgrade to make it work so it should be fine to stay on 3.x.

    That being said, the current version of redsn0w will NOT work for a 3.x iOS -- redsn0w and PwnageTool are specific to the iOS builds they work on -- newer ones do not automatically (to the contrary, rarely if ever) work with previous versions. If you were trying to jailbreak iOS 3.1.2, you'd use PwnageTool 3.1.4 or redsn0w 0.9.2. Newer builds will not work, they will fail to identify the .IPSW and refuse to do anything.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


 

 

Similar Threads

  1. Failed to Jailbreak Iphone 3GS with pawnage tool 3.1.4
    By saiyukicloud in forum Blackra1n (3G(S) jailbreak)
    Replies: 5
    Last Post: 10-30-2009, 09:55 AM
  2. Jailbreak worked! Activate failed...
    By binxia in forum iPod Touch 2G
    Replies: 2
    Last Post: 03-15-2009, 03:37 PM
  3. [1.1.2OTB] Jailbreak Failed
    By Kiwiphone in forum General
    Replies: 1
    Last Post: 02-09-2008, 03:48 AM
  4. [1.1.3] DevTeam Jailbreak Failed on Mac
    By iMaso in forum iPhone "2G" (Rev. 1)
    Replies: 14
    Last Post: 01-28-2008, 03:57 PM
  5. [1.1.1 OTB] Oktoprep > upgrade 1.1.2 > jailbreak 1.1.2 failed
    By trotty in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 01-12-2008, 10:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:31 PM.
twitter, follow us!