Results 1 to 3 of 3
Discuss Rogers SIM in Fido Iphone - Internet not working? at the iPhone 3G - Hackint0sh.org; Hi, I have a strange issue. I have a Fido (Canada) Iphone 3g with custom ...
  1. #1
    Newbie Array

    Join Date
    Mar 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Rogers SIM in Fido Iphone - Internet not working?

    Hi,

    I have a strange issue. I have a Fido (Canada) Iphone 3g with custom 2.2 FW and 2.11.07 broadband.

    In December, I have successfully used it in Europe with gevey-3g, I was playing around with it here in Canada and noticed something weird.

    If I put a Rogers sim card without the adapter, obviously it does not work (even though Rogers own Fido). If I use the gevey adapter, I am able to register on the Rogers network and make/receive calls. HOWEVER, I am not able to get on the Internet ALTHOUGH it shows the 3G sign.

    If I use SBSettings, it shows NO DATA IP ADDRESS. I also tried turning off 3G and use EDGE (through boss prefs), and the result was the same - no Internet.

    I have tried with 2 different Rogers SIMs - one coming from a Rogers Iphone with 6gb data plan.

    What could be the problem?

    Thanks in advance.

    PS
    I have not upgraded the modem to 2.28 with yellowsn0w coz I know some people are having issues and gevey has worked fine for me in Europe, so I don't want to take chances.



  2. #2
    Newbie Array

    Join Date
    Mar 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I also tried changing suggested APN settings I found on the Internet, but it did not seems to help.

    anyone?

  3. #3
    Newbie Array

    Join Date
    Mar 2009
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    OK, figured it out.

    Basically, when I created the custom 2.2 firmware (no broadband update), I selected the "Activate" option. It seems that the phone was not activated properly.

    I downgraded to 2.1 and activated with a Fido SIM, created a new custom 2.2 ipsw with DO NOT ACTIVATE option, and it works fine after activating with a Fido SIM.

 

 

Similar Threads

  1. MacNN: Rogers and Fido introduce new iPhone plans
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 10-03-2008, 05:50 PM
  2. Replies: 6
    Last Post: 08-07-2008, 09:46 PM
  3. Replies: 2
    Last Post: 08-04-2008, 04:58 PM
  4. Fido iPhone 3G on Rogers network?
    By -cj- in forum iPhone 3G
    Replies: 3
    Last Post: 07-16-2008, 01:45 AM
  5. Replies: 9
    Last Post: 04-01-2008, 09:33 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:30 PM.
twitter, follow us!