need help on updating a really old 3G still on 2.0.1 !!

Printable View