Page 1 of 2 12 LastLast
Results 1 to 10 of 12
Discuss My SpringBoard keeps crashing... at the iPhone 3G - Hackint0sh.org; A message popped up on my screen that says that SpringBoard has just crashed, my ...
  1. #1
    Advanced Array

    Join Date
    Mar 2009
    Posts
    35
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default My SpringBoard keeps crashing...

    A message popped up on my screen that says that SpringBoard has just crashed, my device is in safe mode, and in order to get out, I need to reboot or restart. The problem is, whenever I reboot, I go right back into safe mode and the same message pops up again.




  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by aliveon2legs View Post
    A message popped up on my screen that says that SpringBoard has just crashed, my device is in safe mode, and in order to get out, I need to reboot or restart. The problem is, whenever I reboot, I go right back into safe mode and the same message pops up again.
    The message is pretty clear that some MobileSubstrate addon has caused this. You can see what addons you have installed via SBSettings - More - Mobile Substrate Addons

    If you don't have SBSettings, you need to use iFunBox or similar to manually rename the MobileSubstrate addon that is causing the crash. Also note that iFunBox and similar will only work if you jailbroke with blackra1n and subsequently installed AFC2Add from cydia. Jailbreaking with devteam jailbreaks (redsn0w, pwnagetool) enable AFC support by default.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Advanced Array

    Join Date
    Mar 2009
    Posts
    35
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    The message is pretty clear that some MobileSubstrate addon has caused this. You can see what addons you have installed via SBSettings - More - Mobile Substrate Addons

    If you don't have SBSettings, you need to use iFunBox or similar to manually rename the MobileSubstrate addon that is causing the crash. Also note that iFunBox and similar will only work if you jailbroke with blackra1n and subsequently installed AFC2Add from cydia. Jailbreaking with devteam jailbreaks (redsn0w, pwnagetool) enable AFC support by default.
    I jailbroke with redsn0w, but I have no idea where to find SBSettings.

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by aliveon2legs View Post
    I jailbroke with redsn0w, but I have no idea where to find SBSettings.
    If you don't know what SBSettings is, then you probably have not installed it from Cydia

    You need to use iFunbox, iPhonebrowser etc to navigate to to /Library/MobileSubstrate/DynamicLibraries/ on the iPhone. You will find all the add-ons named xxxxx.dylib for the enabled ones and xxxxx.disabled for the disabled ones.

    Simply rename any add-ons you suspect might be causing the problem to xxxx.disabled and respring. This will probably fix it. The only one you should not rename is libhide. That is from the same author as MobileSubstrate and should be safe.
    Last edited by Olethros; 03-01-2010 at 02:33 PM.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Newbie Array

    Join Date
    Jan 2011
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Did you download the android app?

    did you just download the latest Andriod app??? if yes you could try remove it.. as i try to remove it and i found it was AndriodHD problem.. you could try and see if it solve your problem as it have no harm trying remove 1 app instead of reformat


  6. #6
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    1
    Uploads
    0
    Rep Power
    0

    Default

    Hi there,
    similar issue here: 3G with iOS 4.2.1 and quite normal operation, in other words no cyclic reboots or crashes. Except for multitasking/task switching. Once I double click on home button and tap on an icon to switch to, spring board will crash. Then the alert comes up with apology from mobile substrate.

    I haven't got installed any SB bits and pieces, just the plain PwnageTool defaults plus an update run afterwards kicked off by cydia in order to apply ultrasn0w. During config and building my ipsw, I did check to have multitasking.

    I figured out that mobile substrate is payload of ultrasn0w package.

    What I don't know is what options I have now and which to chose.

    * should I precautionary re-install ultrasn0w in hopes to fix a potential glitch? I'm a bit hesitant here because it has todo with baseband.
    * I could do a complete restore in hopes to have sb crashes gone. But that's a big effort and doesn't bring big chance to fix it.
    * should I install ssh and peek and poke around inside sb settings? I think no because instructions above are already one year old an may be out of date.

    So, I'd love to have someone give me a hint or help on how to solve this. Thanks a lot in advance, bj.


    By the way: as a leaving 3.1.2 user, I cannot say that iOS 4.2.1 is any slower than iOS 3.1.2 on my 3G. So from this viewpoint upgrade was a win.

  7. #7
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Hmm. you sure you don't have Activator installed?
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  8. #8
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    1
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Olethros View Post
    Hmm. you sure you don't have Activator installed?
    I haven't had it installed, then I had it installed along with sbsettings and such. Now 3rd party stuff related to SB is uninstalled again.
    Either way, springboard crashes
    - when tapping on a link in Mail.app or
    - at double-click for tasks in backgound and selecting one or
    - at tapping on address in contacts to see it on Maps.app.

    It did right after freshly installed restore of iOS 4.2.1 (of course prepped by PT). I did one or two reboots since. Phone is 3G.

    Any ideas? Highly appreciated.
    cu, bj.

  9. #9
    Newbie Array

    Join Date
    Jun 2011
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by beingjan View Post
    I haven't had it installed, then I had it installed along with sbsettings and such. Now 3rd party stuff related to SB is uninstalled again.
    Either way, springboard crashes
    - when tapping on a link in Mail.app or
    - at double-click for tasks in backgound and selecting one or
    - at tapping on address in contacts to see it on Maps.app.

    It did right after freshly installed restore of iOS 4.2.1 (of course prepped by PT). I did one or two reboots since. Phone is 3G.

    Any ideas? Highly appreciated.
    cu, bj.
    I just upgraded all my updates on cydia and it fixed it

  10. #10
    Professional Array

    Join Date
    Dec 2009
    Posts
    98
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Default

    I have this problem too and never really thought about it. How can you tell which addon is causing the problem?


 

 
Page 1 of 2 12 LastLast

LinkBacks (?)


Similar Threads

  1. Replies: 2
    Last Post: 08-15-2011, 05:51 PM
  2. Replies: 7
    Last Post: 02-26-2011, 08:34 PM
  3. iPod springboard keeps crashing?!?!?
    By evergreen909 in forum iPod Touch 2G
    Replies: 2
    Last Post: 06-30-2010, 08:56 PM
  4. iphone 3g springboard crashing
    By smokemac in forum Redsn0w
    Replies: 0
    Last Post: 08-29-2009, 11:54 AM
  5. Springboard Crashing in 1.1.1, Can I restore?
    By devinferno in forum iPhone "2G" (Rev. 1)
    Replies: 17
    Last Post: 12-17-2007, 01:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:29 PM.
twitter, follow us!