Results 1 to 6 of 6
Discuss Just some JB questions i need answered at the iPhone 3G - Hackint0sh.org; 1.For example, i wanted to JB my 3.1.3 official firmware iphone to 3.1.3 JB via ...
  1. #1
    Newbie Array

    Join Date
    Nov 2010
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Wink Just some JB questions i need answered

    1.For example, i wanted to JB my 3.1.3 official firmware iphone to 3.1.3 JB via Redsn0w. I know it will work, but will it also work if I was on a lower firmware say 3.1.2 and below?

    2.So from what I understand, once you upgrade your Iphone to 3.1.3 theres no going back, and once you upgrade to iOS 4.0, theres also no going back and this is because for those 2 updates/upgrades the baseband was also updated and prevents any downgrades am i right?

    3.Since Ipod Touches dont have basebands i can always downgrade an ipod touch iOS 4.0 all the way BACK to 2.2.1 via DF mode + 2.2.1 recovery file with no problems right?

    4.My Iphone is 3.1.3 JB, but i want to update to iOS, what is the most compatible iOS 4 right now for an Iphone 3g? Is there even one or are they all slow?

    ..thank you..!



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by j00zl33t View Post
    1.For example, i wanted to JB my 3.1.3 official firmware iphone to 3.1.3 JB via Redsn0w. I know it will work, but will it also work if I was on a lower firmware say 3.1.2 and below?
    Redsn0w 0.9.2 can jb 3.1.3 and 3.1.2 also 3.0 and 3.0.1 on a 3G iPhone
    Quote Originally Posted by j00zl33t View Post
    2.So from what I understand, once you upgrade your Iphone to 3.1.3 theres no going back, and once you upgrade to iOS 4.0, theres also no going back and this is because for those 2 updates/upgrades the baseband was also updated and prevents any downgrades am i right?
    You can go back via dfu mode but that doesn't downgrade baseband. Sometimes new baseband is incompatible with older iOS version. Mostly though it will work ok with mismatched baseband and iOS version. Updated baseband is mostly problem for unlockers.
    Quote Originally Posted by j00zl33t View Post
    3.Since Ipod Touches dont have basebands i can always downgrade an ipod touch iOS 4.0 all the way BACK to 2.2.1 via DF mode + 2.2.1 recovery file with no problems right?
    yes
    Quote Originally Posted by j00zl33t View Post
    4.My Iphone is 3.1.3 JB, but i want to update to iOS, what is the most compatible iOS 4 right now for an Iphone 3g? Is there even one or are they all slow?!
    4.1 is the only one that is reportedly useable. None of the 4.0.x versions run well on 3G. 4.2 is unreleased so cannot yet comment on that.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Nov 2010
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    thanks again for the answers Olethros

    just to clarify one thing though for my first question, ok so you're saying redsn0w 0.9.2 can jailbreak your 3.0.1 or 3.1.2 straight to 3.1.3? The reason why i ask is coz on redsn0w it says 'choose the ipsq of your current firmware'..so basically my question is do you have to be on the same firmware version as whatever firmware version you're trying to JB to? (ex. 3.1.3 official to 3.1.3 JB via redsn0w)

    ...or can i just go straight from 3.0.1 (or lower) and jailbrake straight to 3.1.3 JB via redsn0w WITHOUT updating to 3.1.3 official firmware?

    sorry if that seemed confusing..

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by j00zl33t View Post
    thanks again for the answers Olethros

    just to clarify one thing though for my first question, ok so you're saying redsn0w 0.9.2 can jailbreak your 3.0.1 or 3.1.2 straight to 3.1.3? The reason why i ask is coz on redsn0w it says 'choose the ipsq of your current firmware'..so basically my question is do you have to be on the same firmware version as whatever firmware version you're trying to JB to? (ex. 3.1.3 official to 3.1.3 JB via redsn0w)

    ...or can i just go straight from 3.0.1 (or lower) and jailbrake straight to 3.1.3 JB via redsn0w WITHOUT updating to 3.1.3 official firmware?

    sorry if that seemed confusing..
    You have completely misunderstood this (however it is a common thing to be confused about)

    Redsn0w jailbreaks the os version currently loaded on your iPhone or iPod. Redsn0w never updates the iOS version on your iPhone. You must use iTunes to update or restore your iOS version.

    What gets confusing is that firstly redsn0w asks for an ipsw and secondly I indicated that a single version of redsn0w can jailbreak more than one minor iOS revision

    Redsn0w asks for an ipsw to keep things legitimate. Apple could shut down jailbreaking if jailbreaking tools included Apple's code. So redsn0w asks you to give it an ipsw (apple's code) and it extracts and applies patches to the required files from the ipsw before sending these patched files to the iPhone to perform the jailbreak. This keeps things legal.

    That redsn0w builds it's jailbreak /ramdisk from an ipsw you give it also has a nice side benefit.

    If apple later releases a very very minor iOS revision (eg from 3.0 to 3.0.1 or from 3.1.2 to 3.1.3) only a few files within the ipsw are actually changed (they all are re-encrypted with a new key but when that decrypted 99% of files are identical)

    That means you cab often (but not always) use a version of redsn0w designed fir iOS x.x.0 with x.x.1 or x.x.2 and so on.
    The confusing thing is that in this type of scenario you are say for example running iOS 3 1.3 and you give redsn0w a 3.1.2 ipsw which it can use to jailbreak your device. Trying the same thing with a device running 3.1.3 same redsn0w version and a 3.1.3 ipsw would not work.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Newbie Array

    Join Date
    Nov 2010
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Holy crap..thank you so much you cleared it all up so well..

    I know its unecessary but i cant stop myself from asking..what happens if i have 3.x official firmware and i JB using redsn0w using a 4.x restore.ipsw? Just a crash/error i assume?

    anyway i got my main q's out of the way thank you very much Olethros!


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by j00zl33t View Post
    I know its unecessary but i cant stop myself from asking..what happens if i have 3.x official firmware and i JB using redsn0w using a 4.x restore.ipsw? Just a crash/error i assume?
    I'm assuming you mean that you talked about using redsn0w 0.9.6 or 0.9.5 betas as 0.9.2 won't accept a 4.x IPSW

    I've never actually tested this, but my guess is that it would crash (hopefully before it overwrote your kernel with an incompatible patched 4.0 one).

    Don't do it. Use the right version of redsn0w for the right iOS version.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. Replies: 0
    Last Post: 02-19-2011, 04:19 PM
  2. Installing OSx Soon, questions have not been answered
    By BigDaveyJ in forum Installation
    Replies: 1
    Last Post: 12-29-2008, 06:14 PM
  3. MacNN: Forums: iPhone e-tickets, questions answered
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 07-23-2008, 07:30 PM
  4. Replies: 0
    Last Post: 02-14-2008, 10:30 PM
  5. Replies: 13
    Last Post: 08-22-2007, 12:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 12:56 PM.
twitter, follow us!