Page 1 of 2 12 LastLast
Results 1 to 10 of 13
Discuss iPhone Safari not opening anymore? [AdBlock issue] at the iPhone 3G - Hackint0sh.org; i have a iphone 3g jailbroken and unlocked on firmware 2.2.1. I never ever had ...
  1. #1
    Rookie Array

    Join Date
    Sep 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iPhone Safari not opening anymore? [AdBlock issue]

    i have a iphone 3g jailbroken and unlocked on firmware 2.2.1.

    I never ever had problems with it, around 20 mins ago I opened up safari on the iphone to google something, then click the home button to get outta it and hit the power button on the top to put it into sleep.

    5 mins later, i wanted to check something else so i load up safari again and this time, it just hangs after I loaded it, and 10 seconds later it brings me back to the home screen. I rebooted, turned off/on the phone, cleared the cache and stuff, and still, safari wont load.

    I crash the spring board on purpose to get the phone into safe mode b/c wanted to see if safari would load in safe mode and lil did I know, after crashing it, being in safe mode, load up safari, and it loads with no problem. WTF, so im like ok, maybe its fixed, I reboot the phone to get outta safe mode, load safari, and bam, hangs for 10 seconds then brings me back to the home screen. Wtf is going on?

    How can I fix this? plz someone help me, im going away for the weekened for an 8hr car ride and I need my phone to work so I can still be on the internet and not be bored as fuk. LOL



  2. #2
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    BHARAT
    Posts
    100
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    Same thing happened to me today.

    U need to have SBSettings installed.

    1) Keep Wifi on.
    2) Open Safari and when u r on the hung screen (not able to tap on anything), swipe to activate SBSettings and turn off the Wifi
    3) Your Safari should start working again and display the msg that internet connectivity not available.
    4) Turn on wifi and enjoy the safari ride !

    It worked for me all right. Do let me know if it worked for you or not.


    P.S. : I am not aaware about the 3G interaction with this stuff. I would suggest that you turn off 3G for a while and then follow the above steps.
    Last edited by indsha008; 02-13-2009 at 09:12 PM.

  3. #3
    Rookie Array

    Join Date
    Sep 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by indsha008 View Post
    Same thing happened to me today.

    U need to have SBSettings installed.

    1) Keep Wifi on.
    2) Open Safari and when u r on the hung screen (not able to tap on anything), swipe to activate SBSettings and turn off the Wifi
    3) Your Safari should start working again and display the msg that internet connectivity not available.
    4) Turn on wifi and enjoy the safari ride !

    It worked for me all right. Do let me know if it worked for you or not.


    P.S. : I am not aaware about the 3G interaction with this stuff. I would suggest that you turn off 3G for a while and then follow the above steps.

    dammit, I tried what you said and it still not working, after turning off wifi while safari is hanging, it just stays hanging and then quits out. Im thinking maybe restoring my phone would work but that really is a last resort seeing that I dont wanna sync all my crap back onto my phone b/c it will take like 3 hrs

    any other suggestions?


    HOLD ON A SEC, as soon as I hit post for the above message, I got into safari!! woot woot!

    I did what you said, but seeing how having edge, 3g, and wifi on, when I loaded up safari, and disable wifi, it would just freeze, (meanwhile i still had 3g and edge on)

    So this time b4 loading up safari again to try, I added edge to the SBSettings, turned off edge, so now only wifi and 3g is on, loaded safari, while it hanged turned off wifi (so now only 3g is on) and few seconds later got that error message you said about safari. turned wifi back on, and im able to surf again! sweet!!!!
    you probably just saved me from my 8 hour car ride later tonight LOL, thanks a lot dude, really appreciate it.

    I wonder why safari acted up like that? freaking weird
    Last edited by KiLLCraZy; 02-13-2009 at 09:54 PM.

  4. #4
    Rookie Array DmentD's Avatar

    Join Date
    Jul 2008
    Location
    Midwest
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    What causes this? Went to bed last night phone was fine turned it off woke up turned it on and safari would only work in safe mode. But I did the steps above and all was good. TY

  5. #5
    Newbie Array

    Join Date
    Feb 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Did you guys load Clippy just before the problem began?

    I loaded clippy last night and I think it might have had something to do with it. I uninstalled it and it didn't help though. Might it have damaged safari? The above fix of turning on and off airplane and wifi worked but only as long as safari was running in the background. If I force quit safari it then refuses to start again....


  6. #6
    Rookie Array

    Join Date
    Sep 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    seeing how I can't find anything about this problem on google, (all im getting with google is safari crashes on pple after having it open already, not the problem we have when it wont load up at all) im guessing this is a fairly new problem or maybe it has to do with the carier network or something? that new update when they updated att carrier 2.9 to 3.1 i believe it was could be the source...

  7. #7
    Newbie Array

    Join Date
    Feb 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Nah, I didn't have the carrier upgraded and it happened to me...

    I am now pretty sure it's AdBlock, even though it wasn't on, just having it on the springboard seems to cause this.

    Try removing it if you've got it. That did it for me.

    I even downgraded to 2.2 and that helped until I reinstalled AdBlock. Once removed again, no problem.
    Last edited by Gioele; 02-14-2009 at 01:54 AM.

  8. #8
    Rookie Array

    Join Date
    Sep 2007
    Posts
    10
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yeaup, makes sense, I have adblock installed also. Thanks for the heads up

  9. #9
    Newbie Array

    Join Date
    Feb 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks a lot guys. That worked perfect for me.

    I uninstalled adblock and opened safari and while it hung, I used RIP Dev Hood and turned off wifi and safari started working.

    I do not really understand the connection between these 2 events but it works so everything is good

  10. #10
    Newbie Array

    Join Date
    Feb 2009
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Me 2

    I had the same problem as you guys, I almost restored my iPhone, but luckily I found this thread..

    All I had to do was to remove addBlock, then wuhuuu, Safari is up and running again..

    Thanx one million, you saved me!!


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Browsing and opening local files in mobile Safari?
    By super_copy in forum iPod Touch 1G
    Replies: 2
    Last Post: 12-19-2008, 02:39 PM
  2. [iphone 3G]Anyone having issue with safari?
    By asma123 in forum iPhone 3G
    Replies: 0
    Last Post: 07-30-2008, 07:31 AM
  3. some safari pages not opening
    By badr9 in forum General
    Replies: 2
    Last Post: 03-30-2008, 09:31 PM
  4. [1.1.4] Safari Issue
    By nomz in forum Free Toolchain Software (Cydia App's)
    Replies: 10
    Last Post: 03-22-2008, 09:33 AM
  5. Opening .exe files with Safari
    By fuchan3 in forum Free Toolchain Software (Cydia App's)
    Replies: 4
    Last Post: 02-08-2008, 11:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:50 PM.
twitter, follow us!