Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss iPhone 3G AT&T 2.2.1, cant get 3G to work on o2 UK at the iPhone 3G - Hackint0sh.org; Hi guys I bought a iPhone 3G on AT&T 2.2.1, and bought a rebel sim, ...
  1. #1
    Rookie Array

    Join Date
    Jan 2008
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default iPhone 3G AT&T 2.2.1, cant get 3G to work on o2 UK

    Hi guys

    I bought a iPhone 3G on AT&T 2.2.1, and bought a rebel sim, but cant seems to get the o2 UK 3G Internet to work.
    I have put in APN setting:

    mobile.o2.co.uk
    mobileweb
    password

    the 3g logo doesnt come up

    Please advice what to do

    Thanks



  2. #2
    Speedy Administrator Array n350z's Avatar

    Join Date
    Nov 2007
    Location
    United Kingdom
    Posts
    3,021
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    If your using a Pay&Go 02 UK sim I think you need to have an internet bolt on package

    Also the Pay&Go APN settings are different to the contract one.

    GPRS information and UK settings
    -
    Read the stickies and search the forum before posting!
    Did we solve your problem? +1 us above
    If you want to become a Hackint0sh supporter click here
    ----------
    Follow Hackint0sh Follow Me

  3. #3
    Rookie Array

    Join Date
    Jan 2008
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I am using contract o2 UK

  4. #4
    Senior Professional Array iGun 4 Fun's Avatar

    Join Date
    Dec 2007
    Posts
    374
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    27

    Default

    Quote Originally Posted by shaq View Post
    I am using contract o2 UK
    your settings incorrect mate,

    i am using AT&T iPhone running o2 and it works perfectly

  5. #5
    Rookie Array

    Join Date
    Jan 2008
    Posts
    13
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    iGun 4 Fun,
    What settings do u use for o2 contract on AT&T iphone?
    Please advice me


  6. #6
    Newbie Array

    Join Date
    Mar 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    try these settings

    APN: mobile.o2.co.uk
    Username: vertigo
    Password: password

  7. #7
    Senior Professional Array iGun 4 Fun's Avatar

    Join Date
    Dec 2007
    Posts
    374
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    27

    Default

    Quote Originally Posted by SwEeT GuY View Post
    try these settings

    APN: mobile.o2.co.uk
    Username: vertigo
    Password: password


    That's it..!

  8. #8
    Newbie Array

    Join Date
    Apr 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Help

    I also bought an AT&T 2.21(5H11) and I'm using a piggyback sim card to use the O2 iphone pay monthly contract.
    I inputted cellular data as below and it's not working.

    APN: mobile.o2.co.uk
    Username: vertigo
    Password: password

    When I turned on the 3G, no signal is found but when 3G is off no internet is connected.

    I even tried restarting iphone. no logo of E or dot has ever appeared like it did when I was with a non-iphone O2 contract.

    Do I have click on the update button in itunes whenever I plug my iphone onto my Mac

    thanks

  9. #9
    Professional Array

    Join Date
    Nov 2007
    Posts
    82
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by laneylynn88 View Post
    I also bought an AT&T 2.21(5H11) and I'm using a piggyback sim card to use the O2 iphone pay monthly contract.
    I inputted cellular data as below and it's not working.

    APN: mobile.o2.co.uk
    Username: vertigo
    Password: password

    When I turned on the 3G, no signal is found but when 3G is off no internet is connected.

    I even tried restarting iphone. no logo of E or dot has ever appeared like it did when I was with a non-iphone O2 contract.

    Do I have click on the update button in itunes whenever I plug my iphone onto my Mac

    thanks
    Which piggyback simcard are you using? I know alot of people using rebel and grevey and both work like a charm. I am not sure all piggyback simcards work that well with mobile net.

  10. #10
    Newbie Array

    Join Date
    Apr 2009
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Smile

    it's a Plus2 Gevey 3G piggyback sim card I bought from chinatown london and they told me i only needed the piggyback instead of the jailbreaking program becuse my iPhone is a 2.2.1 (5H11).

    sometimes I'm able to see the 'E' logo but the internet doesn't seem to be connected.

    Is it not possible to get O2 3G to work at all on a AT&T iPhone?

    I'm on an iPhone monthy tariff with O2.

    Thanks


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 18
    Last Post: 08-22-2012, 07:04 PM
  2. Replies: 9
    Last Post: 04-01-2010, 05:42 PM
  3. D-link wireless net work card does not work ..
    By iphonegreek in forum Hardware
    Replies: 3
    Last Post: 11-05-2008, 09:39 AM
  4. Replies: 10
    Last Post: 01-23-2008, 05:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:31 AM.
twitter, follow us!