For those of us wondering if OTB FW 3.1 can be unlocked, the answer is still NO

George Hotz (geohot) on Twitter
..."3.1.2...still vulnerable and blackra1n worked perfectly on my 3gs"
... "jailbreak wise"
..."but ... NO UNLOCK if you upgrade" (to FW 3.1+)