Results 1 to 4 of 4
Discuss EDGE/3G Network Problem at the iPhone 3G - Hackint0sh.org; I'm not sure where else to go with this type of problem, and I figured ...
  1. #1
    Newbie Array

    Join Date
    Feb 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Unhappy EDGE/3G Network Problem

    I'm not sure where else to go with this type of problem, and I figured this is probably one of the better places.

    A few days ago I had that dreaded "please connect to iTunes to enable Push Notifications" problem going on; totally unwarranted as I hadn't done anything to make it happen, but from what I gather it can happen more or less whenever your iPhone feels like giving up the certificate. Anyways, I digress. So, as opposed to spending a few bucks or doing any of the other "fixes" I just decided to restore my iPhone, then re-jailbreak it.

    I did so using redsn0w. I accidentally upgraded to 3.1.3 firmware, but at least redsn0w could still jailbreak it, right? Well, after trying blackra1n, sn0wbreeze, and then just going back to redsn0w, I got my iPhone re-jailbroken - and the push notification problem solved.

    Okay, so after all that, I get my phone going and working and all that stuff, and I find that it now only displays the "E" for EDGE network on my statusbar. So, I get SBSettings, toggle the E off, and EDGE is still on. I turn 3G on/off also. No go. WiFi, anything having to do with the network I try to mess with. Nothing works. I also tried changing the wifi/3G settings in the actual settings section - to no avail! I know I was getting a 3G signal at my house and in my town before, but now I don't have it. So I don't know if i provided too much or too little information, but does anyone have any clue what could be wrong? I'm stuck here, and honestly it really detracts from the idea of having a 3G iPhone if you're not getting 3G data... which I'm paying for!

    I'm using an iPhone 3G with an AT&T data plan, so it's for the most part pretty legit.

    Sorry for the long and noobish post, but I've run out of options here and I figured you guys may have some idea as to what the problem is. In my defense, googling any phrase with the word "3G" in it really comes up with too many results and none of them seem to relate.



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by birdvsworm View Post
    I'm not sure where else to go with this type of problem, and I figured this is probably one of the better places.

    A few days ago I had that dreaded "please connect to iTunes to enable Push Notifications" problem going on; totally unwarranted as I hadn't done anything to make it happen, but from what I gather it can happen more or less whenever your iPhone feels like giving up the certificate. Anyways, I digress. So, as opposed to spending a few bucks or doing any of the other "fixes" I just decided to restore my iPhone, then re-jailbreak it.

    I did so using redsn0w. I accidentally upgraded to 3.1.3 firmware, but at least redsn0w could still jailbreak it, right? Well, after trying blackra1n, sn0wbreeze, and then just going back to redsn0w, I got my iPhone re-jailbroken - and the push notification problem solved.

    Okay, so after all that, I get my phone going and working and all that stuff, and I find that it now only displays the "E" for EDGE network on my statusbar. So, I get SBSettings, toggle the E off, and EDGE is still on. I turn 3G on/off also. No go. WiFi, anything having to do with the network I try to mess with. Nothing works. I also tried changing the wifi/3G settings in the actual settings section - to no avail! I know I was getting a 3G signal at my house and in my town before, but now I don't have it. So I don't know if i provided too much or too little information, but does anyone have any clue what could be wrong? I'm stuck here, and honestly it really detracts from the idea of having a 3G iPhone if you're not getting 3G data... which I'm paying for!

    I'm using an iPhone 3G with an AT&T data plan, so it's for the most part pretty legit.

    Sorry for the long and noobish post, but I've run out of options here and I figured you guys may have some idea as to what the problem is. In my defense, googling any phrase with the word "3G" in it really comes up with too many results and none of them seem to relate.
    Restore a fresh 3.1.3, then jailbreak directly with redsn0w (using the 3.1.2 IPSW trick). Make sure your AT&T SIM is inserted during the jailbreak.

    Try a reset all network settings as well.
    Additionally, try your troubleshooting without using sbsettings or other addons. Get the base iPhone OS working before adding other things to the mix. (this is basic troubleshooting)

    As for the E symbol. It is technically impossible to fuly disable EDGE on the iPhone. The most recent Edge toggle (from last week) in SBSettings sets an invalid IP address on EDGE. This breaks both 3G and EDGE. Maybe this new toggle has some bugs. None of the previous EDGE SBSettings toggles worked well either.
    Last edited by Olethros; 02-16-2010 at 08:24 AM.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Newbie Array

    Join Date
    Feb 2010
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Restored

    So I'm currently sitting here with my iPhone set to 3.1.3 firmware, pretty much untouched. And I'm still on Edge. No 3G icon. Ever. I've tried restoring at least five times; a couple times with no backup (so brand-newish?), and an equal amount of times with my backed up contacts. Nothing.

    Could this have anything to do with it? Two days ago when I was trying to fix my "connect to iTunes to use Push Notifications" problem, i tried doing a restore with 3G disabled? I don't know what the problem could be! I'm getting desperate, does anyone know an app/program I could use to maybe monitor/check to see if I have any 3G signal coming into my phone? I can't get this figured out!

    In other news, when I do go into the "network" section and toggle the 3G functionality off, Edge takes over almost right away. But if I turn 3G on, it sits there for a minute or two with a "No Service" replacing the signal, and eventually finds the connection - Edge though. APN editing doesn't even download on my iPhone when I go to get it, I get errors.

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by birdvsworm View Post
    So I'm currently sitting here with my iPhone set to 3.1.3 firmware, pretty much untouched. And I'm still on Edge. No 3G icon. Ever. I've tried restoring at least five times; a couple times with no backup (so brand-newish?), and an equal amount of times with my backed up contacts. Nothing.

    Could this have anything to do with it? Two days ago when I was trying to fix my "connect to iTunes to use Push Notifications" problem, i tried doing a restore with 3G disabled? I don't know what the problem could be! I'm getting desperate, does anyone know an app/program I could use to maybe monitor/check to see if I have any 3G signal coming into my phone? I can't get this figured out!

    In other news, when I do go into the "network" section and toggle the 3G functionality off, Edge takes over almost right away. But if I turn 3G on, it sits there for a minute or two with a "No Service" replacing the signal, and eventually finds the connection - Edge though. APN editing doesn't even download on my iPhone when I go to get it, I get errors.
    Are you sure you actually can get 3G coverage in your house? Have you tried in different locations? Or with another phone on the same network (preferably same sim card).

    What baseband version do you have?

    Can you get a syslog of your iPhone booting up?

    There is a syslog sbsettings toggle available in Cydia. Install that, turn on syslog, restart the phone (with 3G option enabled before you restart)

    Grab the log file from /var/log/syslog with iPhone Browser, DiskAid or similar and then post it on pastebin.com and reply to this thread with a link to your pastebin posting.

    For more information regarding syslog, see: System Log - The iPhone Wiki
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

 

 

Similar Threads

  1. How do you turn Edge Network OFF?
    By timothy1 in forum iPhone 3G
    Replies: 12
    Last Post: 08-07-2009, 10:48 PM
  2. Replies: 16
    Last Post: 07-07-2008, 05:58 AM
  3. Edge Network
    By IphoneFSU in forum iPhone "2G" (Rev. 1)
    Replies: 8
    Last Post: 04-15-2008, 08:20 PM
  4. Edge not working? Network down? Anyone else?...
    By myztikal47 in forum General
    Replies: 1
    Last Post: 10-12-2007, 06:32 AM
  5. Edge connections problem with a iphone registered w/modded SIM in a foreign network
    By Palu in forum Turbo-, Supersim and Simcloning Solution
    Replies: 9
    Last Post: 08-01-2007, 04:35 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:00 PM.
twitter, follow us!