Page 1 of 2 12 LastLast
Results 1 to 10 of 14
Discuss [ZiPhone] What's the purpose of -b, downgrading the bootloader? at the iPhone "2G" (Rev. 1) - Hackint0sh.org; I'm trying to understand how these things work. Why would a person want to downgrade ...
  1. #1
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    119
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default [ZiPhone] What's the purpose of -b, downgrading the bootloader?

    I'm trying to understand how these things work. Why would a person want to downgrade the baseband of an oob 1.1.2 or 1.1.3 with ziphone?

    Apparently the -b command will downgrade the bootloader to 3.9 and upgrade the baseband (?) to 4.03.13_G. Although the baseband was already 4.03, right? Seems there are many inconsistencies of info with ziphone.

    Now, if I could take a oob 1.1.3 phone and downgrade the bootloader to 3.9 and keep the 4.03 baseband and unlock it, it would still work, no? Maps locate me would work? Is that the point?

    THANKS FOR YOUR RESPONSES.



  2. #2
    Professional Array

    Join Date
    Feb 2008
    Posts
    66
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Yes,

    Because the 4.6 Bootloader has tougher security, so the 3.9Bootloader downgrade is to get the unlocked 04.03 BB to work with 1.1.3. Ziphone currently unlocks 1.1.3 OTB but downgrades the BB to 04.02. But get locateme on Repo in installer to get it to work

    Mike

  3. #3
    drg
    drg is offline
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    Canada
    Posts
    479
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    Quote Originally Posted by sura View Post
    Seems there are many inconsistencies of info with ziphone.
    This is not inconsistent.

    The ZI -b option will downgrade the bootloader to 3.9 to allow a patched unlocked 4.0.13 to run. Yes, you had 4.03.13 before the BL downgrade, but was it unlocked? No.

    The BL downgrade is required for 4.03.13 because of something geohot calls "full-range checking" when it is paired with BL4.6. Pairing BL3.9 and 4.0.13 does not cause full-range checking, and allows excution of unsigned code. This latter situation also applies to OTB BL3.9 who ran anySIM 1.3.

  4. #4
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    119
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    OK, maybe not inconsistent but hard for me to follow.

    If I wanted to try this on a virgin oob 1.1.3 what would the correct sequence be... jailbreak, activate, downgrade/unlock?

    Or -j -a -u then downgrade?

  5. #5
    drg
    drg is offline
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    Canada
    Posts
    479
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    Decide if you want to downgrade the BL, there are pros and cons. Different people will tell you different things.

    If you decide to downgrade the BL, then -j -a -b.

    If no, then -j -a -u.

    Issue all the commands at the same time. Everything will happen in sequence.

    Don't forget to add -v to both if you are still using ZI2.0...


  6. #6
    Rookie Array

    Join Date
    Nov 2007
    Posts
    22
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Just read the instruction.
    If you just got the phone, do it all!

  7. #7
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    419
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Look at it like this:

    In the future well each new firmware apple realeases with Bootloader 3.9 you will be able to unlock it becasue of the loopholes 3.9 has, but with 4.6 you wont be able to unlock it.

    And worst once you update to new firmware the baseband updates too and then you wont be able to downgrade the BOOTLOADER to 3.9 even to unlock it!!!

    Thats why i downgraded to 3.9 becasue then i am safe

  8. #8
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    119
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    I think I'll try it. If I downgrade the baseband, it can't be upgraded later, right?

  9. #9
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    419
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    BASEBAND updates when ever there is a new firmware by APPLE, but if your on Booltoader 3.9 your safe because you can alays downgrade your baseband software to an older one and get FULL iphone functions the phone and everything. But with Bootloader 4.6 you wont be able to do that so say 1.1.4 comes out you updated then your stuck at the activate screen. And you cant downgrade to 3.9 then. SO I SAY downgrade to 3.9 as soon as possible. COZ your safe

  10. #10
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    119
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    I tried it. v. 2.4 OS X. When finished, ziphone said:

    ERROR: ziphone returned 1

    The phone is back to the slide for emergency screen.

    What's up?


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 4
    Last Post: 03-11-2008, 01:02 AM
  2. [1.1.3 otb]ziphone 2.4 unlock without downgrading!!
    By niksy_nik7 in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 02-23-2008, 07:56 AM
  3. [1.0.2 (1.1.2 OTB)][Problem downgrading bootloader]
    By unknownuser in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 02-02-2008, 05:39 PM
  4. [Testpoint] Downgrading Bootloader from 4.6 to 3.9
    By SamB in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 01-29-2008, 12:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 08:54 PM.
twitter, follow us!