Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss Unlocked 1.0.2 upgrade to 1.1.4 at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Hi Guys, I bought an unlocked iPhone from America over 2 years ago with 1.0.2 ...
  1. #1
    Newbie Array vanilth's Avatar

    Join Date
    Jun 2009
    Location
    Birmingham, UK
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Red face Unlocked 1.0.2 upgrade to 1.1.4

    Hi Guys,

    I bought an unlocked iPhone from America over 2 years ago with 1.0.2 firmware.
    Not sure what method was used to unlock it but it was right at the start of the first launch of iPhone.
    I am now tired of not being able to update the firmware and would like to give it a shot.
    I have been researching on how to do this and found that due to it being unlocked with 1.0.2 I need to Virginize my iphone.
    I have downloaded Ziphone 3.0.
    Am I right to use Ziphone to erase 3.9 bootloader and then restore firmware to 1.1.4 by pressing "Prepare for upgrade" then go to iTunes press "shift" whilst clicking on restore and choose file for 1.1.4 firmware.
    When restored go to Ziphone and press "Do it all" and it should be unlocked jailbreaked and upgraded 1.1.4 ?

    Should I upgrade my iPhone this way or is there a simpler/better way of doing this?


    I am very thankful for any help

    thanks Vanilth



  2. #2
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    First of all, dont use Ziphone at all, we have so many users having turned their iPhone into a brick with this "tool".

    If the iPhone was unlocked at firmware 1.0.2 by software, AnySIM 1.0.2 was used. The solution damaged the seczone, the iPhone should be virginized - at least if you want to be on the safe side.

    If you are still at 1.0.2, check this one here:

    http://www.hackint0sh.org/forum/f136/68400.htm

    When done, right at the end of the how-to, DFU-restore to Apple Stock firmware 3.0 instead of 2.2.1. for that to work, iTunes 8.2 has to be installed on your iphone.

    When done, the iphone is locked at firmware 3.0. To jailbreak, unlock, activate use the tutorial here:

    iClarified - iPhone - How to Unlock/Jailbreak Your iPhone 2G on OS 3.0 Using RedSn0w (Windows)

    or here

    iClarified - iPhone - How to Unlock/Jailbreak Your iPhone 2G on OS 3.0 Using RedSn0w (Mac)

    Tipp: After that, connect the iPhone to iTunes. If iTunes offers to "restore data from a backup", dont choose this one it might bring back old outdated prefs to the iPhoen that cause trouble. Choose "Setup as a new iPhone instead". After that synchronize the iPhone and you are set.

    happy hacking,
    v.
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  3. #3
    Newbie Array vanilth's Avatar

    Join Date
    Jun 2009
    Location
    Birmingham, UK
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks for your very fast reply.
    I have installed iLiberty all ready to start, my only concern is that I don't know what basband I have and can't really check.
    Should my baseband be baseband 03.14.08 ?
    Not sure if it is of any help but my modem firmware is 04.01.13_G
    Thanks again

    Vanilth

  4. #4
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by vanilth View Post
    Thanks for your very fast reply.
    I have installed iLiberty all ready to start, my only concern is that I don't know what basband I have and can't really check.
    Should my baseband be baseband 03.14.08 ?
    Not sure if it is of any help but my modem firmware is 04.01.13_G
    Thanks again

    Vanilth
    Uups! baseband = modem fiirmware
    So you got the baseband (modem firmware) that belongs to firmware 1.1.1 not 1.0.2. The Virginizer wont work with this combination.

    Is Anysim still installed on the iPhone? If so, can you find out wich version?
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2

  5. #5
    Newbie Array vanilth's Avatar

    Join Date
    Jun 2009
    Location
    Birmingham, UK
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I dont have Anysim installed on my iPhone, as far I know. I dont have installer and I did try before to install it but never worked.
    Is there any way of updating my iPhone?

    thanks

    vanilth


  6. #6
    Newbie Array vanilth's Avatar

    Join Date
    Jun 2009
    Location
    Birmingham, UK
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Question Upgrade unlocked 1.0.2 with baseband 04.01.13_G

    Hi again,

    I have researched how to upgrade my iPhone but not getting anywhere.
    Is there any way for me to upgrade my iPhone or should I sell it and buy a new one?

    I am very thankful for any help.

    Vanilth

  7. #7
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    If you have Baseband/modem = 04.01.14_G then you don't have to worry about virginize and you can update to 2.x or 3.0 directly. Once that is done, you can use current tool to jailbreak/hacktivate and unlock the phone. Note: Quickpwn 2.2.5 is for fw 2.x & redsnow 0.7.2 is for fw 3.0

    The worry with virginize applies only to BB=03.14.08_G (fw 1.0.2)that was unlocked with older AnySim, fast-unlock.pxl that causes a corrupted seczone in the baseband. Since your baseband has been updated, someone must have gone through the process of virginizing before they updated it.
    Last edited by dtube; 06-25-2009 at 11:17 PM.
    ** If you just want to support hackint0sh.org with a donation click here **

  8. #8
    Newbie Array

    Join Date
    Oct 2007
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    It's exactly what I need but I don't have a PC but a Mac!
    So what's the software to replace iLiberty?
    Thx



    Quote Originally Posted by volkspost View Post
    First of all, dont use Ziphone at all, we have so many users having turned their iPhone into a brick with this "tool".

    If the iPhone was unlocked at firmware 1.0.2 by software, AnySIM 1.0.2 was used. The solution damaged the seczone, the iPhone should be virginized - at least if you want to be on the safe side.

    If you are still at 1.0.2, check this one here:

    http://www.hackint0sh.org/forum/f136/68400.htm

    When done, right at the end of the how-to, DFU-restore to Apple Stock firmware 3.0 instead of 2.2.1. for that to work, iTunes 8.2 has to be installed on your iphone.

    When done, the iphone is locked at firmware 3.0. To jailbreak, unlock, activate use the tutorial here:

    iClarified - iPhone - How to Unlock/Jailbreak Your iPhone 2G on OS 3.0 Using RedSn0w (Windows)

    or here

    iClarified - iPhone - How to Unlock/Jailbreak Your iPhone 2G on OS 3.0 Using RedSn0w (Mac)

    Tipp: After that, connect the iPhone to iTunes. If iTunes offers to "restore data from a backup", dont choose this one it might bring back old outdated prefs to the iPhoen that cause trouble. Choose "Setup as a new iPhone instead". After that synchronize the iPhone and you are set.

    happy hacking,
    v.

  9. #9
    Newbie Array

    Join Date
    Oct 2007
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Is the payload available for iLibertyX (Mac)?

  10. #10
    iPhone Moderator Array

    Join Date
    Aug 2007
    Posts
    3,620
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    220

    Default

    Quote Originally Posted by biquet1 View Post
    Is the payload available for iLibertyX (Mac)?
    Sorry, but the payload is only available for Windows, way easier to make ;-)
    Read the stickies and search the forum before posting!
    If you want to become a Hackint0sh supporter click here
    ----------
    iPhone 4 factory unlocked, iOS 4.3.1, jailbroken
    iPad Wi-Fi + 3G (1G), iOS 4.3.1, jailbroken
    iPad 2


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 09-21-2008, 02:34 AM
  2. [1.0.2] (geohot unlocked) upgrade to 1.1.1 (unlocked)
    By h4x0r911 in forum iPhone "2G" (Rev. 1)
    Replies: 8
    Last Post: 03-09-2008, 09:12 PM
  3. [1.1.1 OTB] Anysim 1.1. unlocked.. upgrade to 1.1.3 unlocked.
    By uPhone in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 02-26-2008, 10:31 PM
  4. Replies: 11
    Last Post: 02-09-2008, 11:35 AM
  5. iphone 1.0.2 unlocked successfully upgrade to 1.1.1 and unlocked
    By fowwiee in forum iPhone "2G" (Rev. 1)
    Replies: 19
    Last Post: 10-23-2007, 04:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:48 AM.
twitter, follow us!