Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss Quick Question at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Hi sorry for the Noobism, but is it not possible to unlock an out of ...
  1. #1
    Newbie Array

    Join Date
    Dec 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Quick Question

    Hi sorry for the Noobism, but is it not possible to unlock an out of the box 1.1.2 even if you downgrade it to 1.1.1 and activate/jailbreak etc?

    I thought it was possible to unlock a 1.1.1 iphone? Is it something to do with the bootloader? Sorry but many thanks!

    Also would it be best to wait and buy a 1.1.3 iphone?

    By the way remember everyone was a noob once!



  2. #2
    Senior Professional Array cortx7's Avatar

    Join Date
    Dec 2007
    Location
    Curitiba - PR - Brazil
    Posts
    337
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by JimboMatrix View Post
    Hi sorry for the Noobism, but is it not possible to unlock an out of the box 1.1.2 even if you downgrade it to 1.1.1 and activate/jailbreak etc?
    No, it is not possible.

    Quote Originally Posted by JimboMatrix View Post
    I thought it was possible to unlock a 1.1.1 iphone? Is it something to do with the bootloader? Sorry but many thanks!
    Yes, it has something to do with the bootloader.

    Quote Originally Posted by JimboMatrix View Post
    Also would it be best to wait and buy a 1.1.3 iphone?
    It would be best for you to buy an 1.1.2 OOTB phone and wait for Apple to release the 1.1.3 firmware.

    Another little thing: Do you see that little gray bar on the top of the page? Alright. Can you see a button called "Search"? It's right next to the "New Posts" button. Yep, that's right. You should use it sometimes! It really helps.

  3. #3
    Professional Array chivopelado's Avatar

    Join Date
    Oct 2007
    Posts
    74
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    No, it is not possible. And please people be nice to him, is his first post.

  4. #4
    Senior Professional Array cortx7's Avatar

    Join Date
    Dec 2007
    Location
    Curitiba - PR - Brazil
    Posts
    337
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by chivopelado View Post
    No, it is not possible. And please people be nice to him, is his first post.
    That doesn't mean he's not able to read the Stickies and try searching for an answer to his question before starting a new thread.

  5. #5
    Supporter Array abc12345's Avatar

    Join Date
    Dec 2007
    Posts
    155
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    You cannot unlock unless February. Now on the way Turbosim or The other clones.


  6. #6
    Advanced Array

    Join Date
    Oct 2007
    Posts
    32
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    rule of thumb: search before posting.

    If people went by that rule we'd get a whole less crap posts in the forums. Especially with 1.1.2otb unlock being posted like twice a day, all of them fake

  7. #7
    Young Padawan Array duck9000's Avatar

    Join Date
    Sep 2007
    Location
    The Outer Rim
    Posts
    2,461
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    149

    Default

    Quote Originally Posted by JimboMatrix View Post
    Hi sorry for the Noobism, but is it not possible to unlock an out of the box 1.1.2 even if you downgrade it to 1.1.1 and activate/jailbreak etc?

    I thought it was possible to unlock a 1.1.1 iphone? Is it something to do with the bootloader? Sorry but many thanks!

    Also would it be best to wait and buy a 1.1.3 iphone?

    By the way remember everyone was a noob once!
    Try reading THIS and THIS. You'll find useful information.
    ** If you just want to support hackint0sh.org with a donation, please click here **.

  8. #8
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    105
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    Quote Originally Posted by cortx7 View Post
    It would be best for you to buy an 1.1.2 OOTB phone and wait for Apple to release the 1.1.3 firmware.
    Sorry, but this isn't very good advice.

    1.1.3 (or whatever the new firmware is) is just the first step to an unlock. A 1.1.3 secpack would allow ieraser to run and erase the firmware, and that's all.

    After that, you'd need to upload an unlocked 1.1.2 firmware. Unlocking a 1.1.2 firmware is easy enough (AnySIM 1.1.2u works just fine), but there is another bigger problem.

    3.9 bootloader sigchecks the baseband ONLY when you flashed a new one but because of an exploitable bug in the bootloader code this could be bypassed, thus allowing the modified baseband with patches applied to be flashed. The 4.x bootloaders appear to sigcheck the baseband on each boot of the phone. Each time an 'unlocked' 4.x phone boots, the bootloader will sigcheck the baseband firmware, see it's not correct (as it's patched), and disable the modem.

    Unless this per-boot-sigcheck can be bypassed (and to my knowledge nobody has shown that this is possible yet) there will still be no unlock, 1.1.3 secpack in hand or otherwise.

    I know a lot of people got in late and are holding these 4.x bootloader phones, waiting for a 1.1.3 update and a dev team unlock, but I really wouldn't get your hopes up. eBay a TurboSIM - this is the most likely way of getting an unlock any time soon.
    Last edited by SimplePanda; 12-14-2007 at 08:56 PM.

  9. #9
    Senior Professional Array cortx7's Avatar

    Join Date
    Dec 2007
    Location
    Curitiba - PR - Brazil
    Posts
    337
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by SimplePanda View Post
    Sorry, but this isn't very good advice.

    1.1.3 (or whatever the new firmware is) is just the first step to an unlock. A 1.1.3 secpack would allow ieraser to run and erase the firmware, and that's all.

    After that, you'd need to upload an unlocked 1.1.2 firmware. Unlocking a 1.1.2 firmware is easy enough (AnySIM 1.1.2u works just fine), but there is another bigger problem.

    3.9 bootloader sigchecks the baseband ONLY when you flashed a new one but because of an exploitable bug in the bootloader code this could be bypassed, thus allowing the modified baseband with patches applied to be flashed. The 4.x bootloaders appear to sigcheck the baseband on each boot of the phone. Each time an 'unlocked' 4.x phone boots, the bootloader will sigcheck the baseband firmware, see it's not correct (as it's patched), and disable the modem.

    Unless this per-boot-sigcheck can be bypassed (and to my knowledge nobody has shown that this is possible yet) there will still be no unlock, 1.1.3 secpack in hand or otherwise.

    I know a lot of people got in late and are holding these 4.x bootloader phones, waiting for a 1.1.3 update and a dev team unlock, but I really wouldn't get your hopes up. eBay a TurboSIM - this is the most likely way of getting an unlock any time soon.
    Yes, I see your point. But what happens if the firmware 1.1.3 gets released, an unlock solution is found (which acts on the 4.6 bootloader) and all the OOTB 1.1.3 iPhones come with an even newer bootloader?
    Then all this time you were waiting to buy an OOTB 1.1.3 iPhone to find out there are no unlocks for your new bootloader, while there is for the 4.6 bootloader. At this point, there probably won't be any more OOTB 1.1.2 iPhones in the stores to buy. So you're screwed until an unlock solution for the newer bootloader comes out. That's what I meant to advise him before.

    And another thing. The TurboSIM method I would mostly NOT recommend at all. Messing with hardware is never a good idea. The TurboSIM method can reduce the lifetime of you phone, not to mention you can cause serious short circuiting.
    Last edited by cortx7; 12-14-2007 at 09:19 PM.

  10. #10
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    105
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    Quote Originally Posted by cortx7 View Post
    Yes, I see your point. But what happens if the firmware 1.1.3 gets released, an unlock solution is found (which acts on the 4.6 bootloader) and all the OOTB 1.1.3 iPhones come with an even newer bootloader?
    Then all this time you were waiting to buy an OOTB 1.1.3 iPhone to find out there are no unlocks for your new bootloader, while there is for the 4.6 bootloader. At this point, there probably won't be any more OOTB 1.1.2 iPhones in the stores to buy. So you're screwed until an unlock solution for the newer bootloader comes out. That's what I meant to advise him before.

    And another thing. The TurboSIM method I would mostly NOT recommend at all. Messing with hardware is never a good idea. The TurboSIM method can reduce the lifetime of you phone, not to mention you can cause serious short circuiting.

    On these points I agree.

    - It's more likely that a 4.xBL/1.1.2 unlock appears than a theoretical "5.x/1.1.3" unlock.

    - TurboSIM is really the only method if you want to use your 4.x/1.1.2 phone NOW. If you do it right, it works pretty well it seems.

    - Best method is to shell out for someone selling a 3.9 phone, if you can still find one. This, of course, is likely to cost you as most people still holding 3.9 equipped phones that are new-in-box know exactly what they are and exactly what they're worth (not $399 USD, that's for sure).

    Every time I come to this forum I smile at my 3.9/1.1.2/anySIM phone.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Quick Question
    By psp_kevin17 in forum Installation
    Replies: 1
    Last Post: 07-10-2011, 06:19 PM
  2. quick question
    By ginsters in forum PwnageTool
    Replies: 0
    Last Post: 04-04-2008, 08:05 PM
  3. A quick question regarding 1.0.2 -> 1.1.3
    By DaMn24 in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 02-18-2008, 07:08 PM
  4. Quick question, pls help
    By vrd in forum General
    Replies: 0
    Last Post: 10-01-2007, 02:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 02:51 AM.
twitter, follow us!