1ste i have reverginized fw 1.0.2 then i updated to fw 1.1.1 unlocked it with anysim.
But after a crash i was forced to recover my iphone in itunes , now iam back at 1.1.1 but i cant unlock it anymore with anysim , and thats because its not verginized anymore offcourse , now iam thinking what about downgrading to 1.0.2 , and try to reverginize then , but iff i would do that will it be able to unlock in 1.1.1 again , or does it need a downgrade + Baseband downgrade ??????

Hope i didnt brick it

Hope you guys can help me out !

Big thnx