Results 1 to 8 of 8
Discuss need some advice "iPhone needs repair..." message and other issues at the iPhone "2G" (Rev. 1) - Hackint0sh.org; i searched all the forums and by now i pretty much know what to do, ...
  1. #1
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default need some advice "iPhone needs repair..." message and other issues

    i searched all the forums and by now i pretty much know what to do, but i am experiencing some trouble with the tools i need.

    what i got: iPhone 2G with 1.0.2(i believe), no imei, no sound, no baseband, no nothing. the only time i managed to get through to the phones information it only showed the serial number, but nothing else, all just empty.

    problem: the iPhone is VERY slow on dial inputs, so the 307 trick doesnt work at all. in addition to that some tools are giving me a hard time. and of course restoring with iTunes gives all kinds of error messages.

    what i did: downloaded iBrickr, iLiberty+/payloads, ziPhone and carnival. used all of them according to the guides found here. best thing i can get was an activated and jailbroken device which can be used as an iPod. no imei, no baseband.....etc as above mentioned.

    by now during all that work it is unactivated again and showing the message "iPhone needs repair, cannot make or receive calls", just like it was when i got it. even iBrickr cant get it back to live, allways green screen, "needs to be restored with iTunes", which obviously doesnt help.

    issues with tools:

    (running windows vista on two different machines with either iTunes 7.4 or iTunes 9.

    ziPhone only works when iTunes properly detects the device, which it doesnt. best thing i can get is a message in iTunes "cannot activate because simcard is wrong or pin-protected."

    so i need to activate it somehow.

    iLiberty is really giving me a hard time! i downloaded it together with the payloads package as linked in that thread here on top of the page "virginize...", renamed the old folder and added the new payloads folder.

    mostly it doesnt work at all, showing me a message "cant create payloads folder". once in a while it seems to work. i am getting lots of text scrolling on the iPhones screen. but it stops somewhere in between with message "payloads not found, skipped that process"(?) and reboots to its former state with "iPhone needs repair" message. in the "advanced" folder i dont see 4 payloads, sometimes only one, and clicking on it is showing starnge behavior. i am not able to download new payloads, all greyed out. sometimes they just disappear when i click on them. but hey are for sure present in the "program files/iLiberty"-folder. i even made a complete fresh install after deleting the old stuff, but still the same. but i remember the very first time i tried iLiberty it showed those four payloads just as requested.

    what i need:

    either to get iLiberty working properly

    or get the iPhone somehow actvated for ziPhone to work

    or get it somehow properly be recognized by iTunes to get ziPhone working

    i also have a mac here at home for the weekends. so if you think some other tools will work better on a mac let me know and i will try.

    thanks a lot for your time!
    Last edited by nehvada; 01-23-2010 at 10:32 AM.



  2. #2
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by nehvada View Post
    i searched all the forums and by now i pretty much know what to do, but i am experiencing some trouble with the tools i need.

    what i got: iPhone 2G with 1.0.2(i believe), no imei, no sound, no baseband, no nothing. the only time i managed to get through to the phones information it only showed the serial number, but nothing else, all just empty.

    problem: the iPhone is VERY slow on dial inputs, so the 307 trick doesnt work at all. in addition to that some tools are giving me a hard time. and of course restoring with iTunes gives all kinds of error messages.

    what i did: downloaded iBrickr, iLiberty+/payloads, ziPhone and carnival. used all of them according to the guides found here. best thing i can get was an activated and jailbroken device which can be used as an iPod. no imei, no baseband.....etc as above mentioned.

    by now during all that work it is unactivated again and showing the message "iPhone needs repair, cannot make or receive calls", just like it was when i got it. even iBrickr cant get it back to live, allways green screen, "needs to be restored with iTunes", which obviously doesnt help.

    issues with tools:

    (running windows vista on two different machines with either iTunes 7.4 or iTunes 9.

    ziPhone only works when iTunes properly detects the device, which it doesnt. best thing i can get is a message in iTunes "cannot activate because simcard is wrong or pin-protected."

    so i need to activate it somehow.

    iLiberty is really giving me a hard time! i downloaded it together with the payloads package as linked in that thread here on top of the page "virginize...", renamed the old folder and added the new payloads folder.

    mostly it doesnt work at all, showing me a message "cant create payloads folder". once in a while it seems to work. i am getting lots of text scrolling on the iPhones screen. but it stops somewhere in between with message "payloads not found, skipped that process"(?) and reboots to its former state with "iPhone needs repair" message. in the "advanced" folder i dont see 4 payloads, sometimes only one, and clicking on it is showing starnge behavior. i am not able to download new payloads, all greyed out. sometimes they just disappear when i click on them. but hey are for sure present in the "program files/iLiberty"-folder. i even made a complete fresh install after deleting the old stuff, but still the same. but i remember the very first time i tried iLiberty it showed those four payloads just as requested.

    what i need:

    either to get iLiberty working properly

    or get the iPhone somehow actvated for ziPhone to work

    or get it somehow properly be recognized by iTunes to get ziPhone working

    i also have a mac here at home for the weekends. so if you think some other tools will work better on a mac let me know and i will try.

    thanks a lot for your time!
    I still think iLiberty is your best bet... Have you changed the repo url in iLiberty? It should be http://iLiberty.insideiphone.com/repo.plist

    Your errors suggest that either iLiberty was installed incorrectly or you aren't running it with admin permissions. Vista is very bad for this, Microsoft's misguided attempt to put security in after the fact.

    Maybe try on XP or the iLiberty version on OS X.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  3. #3
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    ok, works perfectly on another machine with xp.

    iLiberty aborted some proces with a message like "wrong baseband 4.0.4something..."

    now i got even ziphone to work, used it for ersaing baseband, but it got stuck with the big Z on the screen and "iErasing..."

    its now there for like 10 minutes. should i just leave it like that and be pacient or is it messed up anyway?

  4. #4
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by nehvada View Post
    ok, works perfectly on another machine with xp.

    iLiberty aborted some proces with a message like "wrong baseband 4.0.4something..."

    now i got even ziphone to work, used it for ersaing baseband, but it got stuck with the big Z on the screen and "iErasing..."

    its now there for like 10 minutes. should i just leave it like that and be pacient or is it messed up anyway?
    don't use ziphone... ever.

    Aside from that positive news
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  5. #5
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    thanks to ziphone i now have an activated iPod

    ok, whats your suggestion now? it looks like sitting on 1.1.1, but still no imei, no iccid, no modem firmware showing up in "settings -> about"


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by nehvada View Post
    thanks to ziphone i now have an activated iPod

    ok, whats your suggestion now? it looks like sitting on 1.1.1, but still no imei, no iccid, no modem firmware showing up in "settings -> about"
    What payloads have you tried with iLiberty?
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    until now i was only able to use the virginator.sh, but this recognize a wrong baseband 4.0.4.0.5

    so it seems to be 1.1.1 with 4.0.4.0.5 baseband

    the problem with iLiberty is that on vista it doesnt start at all, and on XP the payloads dont show up. its a fresh install on both machines , but no matter where i put the payload pack (from this thread: http://www.hackint0sh.org/f136/68400.htm )they just dont show up on the XP machine.

    Have you changed the repo url in iLiberty? It should be http://iLiberty.insideiphone.com/repo.plist
    i cant find an option where to change that.

  8. #8
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    found the error, it was an older version of iLiberty which the guide has linked me to. so i installed the newest version and was able to proceed.

    what i think i have is an iPhone sitting on 1.1.1 with baseband 4.0.4.0.5_G. this is at least shown soemtimes in the scrolling text or in the settings/generell/about.

    so i used the payloads for downgrading the boot loader which gets stuck at the iPipe with "downgrading bootloader....", but nothing happens.

    then i tried to reflash baseband to 4.01.13 which gets stuck at the same point with "checking bootloader version.....", but nothing happens.

    so i think i have either a totally different bootloader from some higher firmware versions (is there any?), or a completely missing or corrupt bootloader.

    any advice?

 

 

Similar Threads

  1. Replies: 7
    Last Post: 05-26-2008, 11:04 PM
  2. [Advice] Redundant "Needs Repair" error
    By cdoverlaw in forum General
    Replies: 2
    Last Post: 05-17-2008, 09:29 PM
  3. [Advice] "Repair Needed" error
    By Dell in forum iPhone "2G" (Rev. 1)
    Replies: 27
    Last Post: 04-08-2008, 05:09 PM
  4. [1.1.3 OTB] Got "Repair needed" message after unlock attempt
    By Don_Ron in forum iPhone "2G" (Rev. 1)
    Replies: 10
    Last Post: 03-12-2008, 06:18 PM
  5. Replies: 0
    Last Post: 03-11-2008, 02:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:49 AM.
twitter, follow us!