m prepping for the Virginizer then the 1.1.1 update but I am still using itunes 7.3.2.6, and I think I will need the newest version of itunes for the 1.1.1.

Is there any risk to updating itunes from 7.3.2.6 to the newest version.

pacay one click with youtube, activation.
unlocked 1.0.2 with anysim

any help would be appreciated....