Quote Originally Posted by wildonrio View Post
That's exactly what I said. If the bootloader stays the same then we can always unlock by downgrading the firmware and baseband to a previous version. If the bootloader changes then we're screwed.
That's not what I said. I said as long as the bootloader doesn't change, then 1.1.3 buyers can wait for 1.1.4 (or whatever the next firmware version is) for their unlock. If the bootloader changes again, then they might not be able to do even that.

As it stands, 1.1.3 phones will not be unlockable by a simple downgrade even if the bootloader stays the same. They will need a higher secpack version just like 1.1.2 users do -- of course, the next secpack won't be available for 1.1.3 until 1.1.4 or higher is released.