Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Discuss How come no 3.9orig - 3.9FB upgrade? at the iPhone "2G" (Rev. 1) - Hackint0sh.org; How come there's no tools to upgrade (sidegrade?) the original 3.9 BL to 3.9FB? At ...
  1. #1
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default How come no 3.9orig - 3.9FB upgrade?

    How come there's no tools to upgrade (sidegrade?) the original 3.9 BL to 3.9FB? At least as an experiment for the courageous?



  2. #2
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    309
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    23

    Default

    because its impossible
    you shouldnt be able to upgrade or downgrade a bootloader
    a bug in 4.6 was discovered that let you downgrade
    however, 3.9FB CAN be upgraded back to 4.6 because the code that caused the bug in 4.6 was copied into 3.9FB
    Phil | MacBook Pro 2.4GHz Leopard | iPhone 8GB

  3. #3
    Rookie Array

    Join Date
    Dec 2007
    Posts
    11
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I wouldn't go as far as to say its impossible. Obviously its impossible with any current means. However its safe to say that its absolute bottom of the list of priorities. It would take quite a real shot in the dark at this point to find a 3.9bl exploit to allow the upgrade. Anyone smart enough to find one would save themselves the time trying and just crack open thier iPhone and use the testpoint.

    Maybe Zibri should make one since he's the one who was trying to force 3.9BL on everyone, should be no problem since he's such a good coder and has found every breakthrough exploit on the iPhone so far according to him.

    Get out your razor blades to crack open your iPhone cause I have a feeling that's going to be the only way for a long loooong time.

  4. #4
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    419
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    but whats the point of updating back to 4.6?

  5. #5
    Rookie Array

    Join Date
    Jan 2008
    Posts
    12
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Talking

    Quote Originally Posted by pgilder View Post
    because its impossible
    you shouldnt be able to upgrade or downgrade a bootloader
    a bug in 4.6 was discovered that let you downgrade
    however, 3.9FB CAN be upgraded back to 4.6 because the code that caused the bug in 4.6 was copied into 3.9FB
    3.9FB is not 3.9 with the 4.6 bug applied.

    3.9FB is 3.9BL with 4 locations BLANK which is a check used by BL when it decides on whether to allow erase/write.

    That is why, a 4.6FB also exists (4.6BL with the 4 locations blank)


  6. #6
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    OK cool, so if bootloaders are not supposed to be upgraded at any point, why are people so worried about downgrading to 3.9FB rather than 3.9orig?

    There's millions of iphones out there with 3.9 on them OOB, and if Apple ever requires a newer bootloader in the future, then they will have to provide their own bootloader upgrade to everyone, wouldn't they?

    Which would mean everyone who downgraded from 4.6 to 3.9orig would be able to upgrade in the exact same way as the 3.9 OOB people...

    Or am I getting something fundamentally wrong here?

  7. #7
    Advanced Array

    Join Date
    Mar 2008
    Posts
    47
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I think the theory is that when 2.0 comes out there's a possibility that there will need to be a new exploit, to unlock and jailbreak and the likes, that may need a modified bootloader, or be based on an exploit in 4.6...
    i think.

  8. #8
    Rookie Array

    Join Date
    Nov 2007
    Posts
    15
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Sounds like a good possibility... but if the 2.0 unlock does end up relying on an exploit in the 4.6 BL, then all us OOB 3.9 BL people would be out of luck unless:

    (a) Apple includes an upgrade to the 4.6 BL in the 2.0 update
    (b) Someone figures out how to upgrade 3.9 OOB to 4.6

    wouldn't we?

  9. #9
    Advanced Array

    Join Date
    Mar 2008
    Posts
    47
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yep, so the iplus 3.9FB is being evangelised just incase; an attempt a future proofing. I'm pretty sure that if the only exploit to get 2.0 working was via 4.6 there would be enough brains working on it to sort out a software upgrade.
    Although, is there an easy way to restore 3.9FB to 4.6 yet even?

  10. #10
    Senior Professional Array imvirus's Avatar

    Join Date
    Dec 2007
    Posts
    143
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Although, is there an easy way to restore 3.9FB to 4.6 yet even?[/QUOTE]

    I think Iphone tools took care of this part upgrading a 3.9FB to original 4.6BL.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 07-20-2008, 05:20 PM
  2. [Upgrade]OTB 1.1.2 Upgrade to 1.1.4 W/O Unlock/Activate/Jailbreak
    By Allingby in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 05-13-2008, 10:36 AM
  3. Replies: 8
    Last Post: 03-18-2008, 04:37 AM
  4. Replies: 0
    Last Post: 01-25-2008, 08:37 PM
  5. [1.1.3] Jailbreak/Upgrade, does 1.1.2u unlock Survive upgrade?
    By mdfreeman in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 01-25-2008, 04:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:03 PM.
twitter, follow us!