Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss Geo's IPSF - Big Problems at the iPhone "2G" (Rev. 1) - Hackint0sh.org; I have been trying to get Geo's IPSF working on my phone, it's never had ...
  1. #1
    Rookie Array

    Join Date
    Apr 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Geo's IPSF - Big Problems

    I have been trying to get Geo's IPSF working on my phone, it's never had the seczone manipulated before, I've only used "good" AnySIM's but when I try and unlock now I either get a 004999 IMEI or it just doesn't unlock.

    ./process runs correctly with no errors. All instructions run correctly in fact. When I check the locktables both in the seczoneout file and also a norz dump they match that of written unlocked ones.

    I'm performing the unlock with 03.14 purely because thats what iTunes spat out when I had to do a complete restore. I tried with 04.02 last night as well but that gave the same results. I know all the tutorials are for 04.03 but the very nature of this unlock means it should be version independent. Does anyone have any suggestions as to what could be wrong?

    Just for reference, I have always reloaded the virgin seczone between attempts so it's been starting from scratch each time and still not working
    Last edited by argon; 02-06-2008 at 09:47 AM. Reason: Last note



  2. #2
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    352
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    Quote Originally Posted by argon View Post
    I'm performing the unlock with 03.14 purely because thats what iTunes spat out when I had to do a complete restore. I tried with 04.02 last night as well but that gave the same results. I know all the tutorials are for 04.03 but the very nature of this unlock means it should be version independent. Does anyone have any suggestions as to what could be wrong?
    itunes NEVER EVER downgrade baseband on its own... tutorals are for .03. because newest firmware files are added that upgrade baseband to .03. version, tutorals for all other versions are not so much different, except geting and flashing baseband your self, if you didnt got any big errors ipsf probably worked you probably just have fucked up baseband (since you didnt reflash it), i would do full restore to 1.1.3 then downgrade back to 1.1.1 with BB downgrade also... how.. SEARCH!

  3. #3
    Rookie Array

    Join Date
    Apr 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    You misunderstand.. iTunes DOES downgrade baseband...

    http://george.zjlotto.com/index.php/...d-my-baseband/

    iUnlock hung on the erase command.

    Anyway, I AM fully reflashing the appropriate baseband version with the right fls and eep files, I am using the correct seczone. I have restored the backed up seczone several times between attempts and it works as it should, i.e. accepting AT&T SIM but rejecting the O2 one, it is Geo's IPSF not working.

    Please do not treat me like an idiot, I know what I'm doing, it's only because there are NO other reportings of this happening that I asked. I understand you do get a lot of stupid questions but there's no need to be so rude.

  4. #4
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    352
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    Quote Originally Posted by argon View Post
    You misunderstand.. iTunes DOES downgrade baseband...

    http://george.zjlotto.com/index.php/...d-my-baseband/

    iUnlock hung on the erase command.

    Anyway, I AM fully reflashing the appropriate baseband version with the right fls and eep files, I am using the correct seczone. I have restored the backed up seczone several times between attempts and it works as it should, i.e. accepting AT&T SIM but rejecting the O2 one, it is Geo's IPSF not working.

    Please do not treat me like an idiot, I know what I'm doing, it's only because there are NO other reportings of this happening that I asked. I understand you do get a lot of stupid questions but there's no need to be so rude.
    no it doesnt iunlock erases only certain segments just enough to apear as incorrect baseband but well anyway upgrade to 1.1.3 and try there i downgraded and upgraded BB only on my iphone and unlock stayed, ofc iphone didnt work with .01. BB and 1.1.3 but thats another issue, didnt do full downgrade since i frankly cant be arsed with restoring phone for half of day, but if its done properly it SHOULD work :<
    Last edited by SoLoR; 02-06-2008 at 10:54 AM.

  5. #5
    Rookie Array

    Join Date
    Apr 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Nope, didn't work with 04.03.13 either, exactly the same problem, even though AT+CLCK=.... returns OK. The locktables are supposedly correct and I ran everything properly, very perplexing. I think I'll call it a day, and go back to using AnySIM I guess.

    Thanks for trying to help.


  6. #6
    Rookie Array

    Join Date
    Jan 2008
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I'm having exactly the same problem.

    Patch changed seczone at :
    1- 0x0400 to 0x047E
    2- 0x0C88 to 0x0D67
    3-the last 4 bytes of my original seczone were C9D8, the patched one FFFF.

    Is this correct behaviour?

    PD: Check PM argon.

  7. #7
    drg
    drg is offline
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    Canada
    Posts
    479
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    argon & cosmass: If you guys figure this out, be sure to post here... Undoubtedly someone will run into the same problem you guys have sooner or later.

  8. #8
    Rookie Array

    Join Date
    Jan 2008
    Posts
    26
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Just to let you know. Its not working.

    The AT unlock command never worked for me. Tried 2 times and i always ended with a 0049 imei and at command not working.
    Restored original seczone betwen attempts.

    Im back with the original seczone and AnySim, and the phone is working as it should.

    Mine is a 1.1.2OTB(UK) with H/W downgrade to 3.9 BL.

  9. #9
    Rookie Array

    Join Date
    Apr 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I think I've narrowed the problem down to the secloader file. If I try and restore the original seczone by `cat secloader seczone > fsecloader` then the restore doesn't actually work, still left with 004999. But if I use a loader generated with geomaker.exe then it restores correctly.

    I am going to try setting up a spoof IPSF server and using SimFree.app to see if that works at all.

  10. #10
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    352
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    also noticed today some strange behavior, needed to downgrade and go again since i fucked up startup procedure so i decided ill also downgrade BB just for fun to see if it really doesnt work without problems, well i have 0499 imei on any baseband but .03. and ofc phone doesnt work... ill check few more things...


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 24
    Last Post: 04-25-2008, 07:18 AM
  2. Replies: 354
    Last Post: 02-15-2008, 06:34 PM
  3. Replies: 1
    Last Post: 09-12-2007, 08:30 PM
  4. Replies: 1
    Last Post: 09-11-2007, 10:35 PM
  5. Replies: 1
    Last Post: 09-11-2007, 09:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:30 AM.
twitter, follow us!