Results 1 to 10 of 10
Discuss Geohot SW unlock on BL 3.9? at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Hi all Has anyone tried the new Geohot software unlock on BL 3.9 phones (OTB ...
  1. #1
    Newbie Array

    Join Date
    Jan 2008
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Geohot SW unlock on BL 3.9?

    Hi all

    Has anyone tried the new Geohot software unlock on BL 3.9 phones (OTB or HW downgraded)? It seems like a much better method than Anysim but I'm not sure if it'll work

    thx



  2. #2
    Senior Professional Array smirkis's Avatar

    Join Date
    Dec 2007
    Posts
    361
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    wont work.

    3.9 stick to anysim

    4.6 iphones stick with geohotz
    originally OTB 1.1.2 iPhone 4.6BL
    hActivated/Jailbroken/gUnlocked
    Tzones hacked
    T-Mobile USA

    now blackra1n'd 3.1.2

  3. #3
    Rookie Array

    Join Date
    Oct 2007
    Posts
    22
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by atomicster View Post
    Hi all

    Has anyone tried the new Geohot software unlock on BL 3.9 phones (OTB or HW downgraded)? It seems like a much better method than Anysim but I'm not sure if it'll work

    thx
    I agree it is a better method.
    But this will not work with BL3.9.

    For now, we better stick with AnySIM and wait for an official AnySIM for 1.1.3 baseband.

  4. #4
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default

    I can't understand this mixed interpretations.

    If you have a BL 3.9 you have 2 "safe" options at this time:

    1) anySIM on 1.1.2

    This allows a true 1.1.2
    and a "mixed" 1.1.3 (1.1.3 OS with 1.1.2 baseband) - this one has some limitations


    2) GeoHot IPSF style unlock. This is one of the 2 unlocks GeoHot released in the past few days. This one is BL 3.9 only and will do exactly the same as IPSF.

    This works for 1.1.2 and for 1.1.3 (requires a special script at boot time)
    This will produce a real (soft-upgraded) 1.1.3


    On the other hand, the latest GeoHot BL 4.6 unlock is what its name says: only for BL 4.6 (HW downgraded BL 4.6 to 3.9 counts are BL 3.9, so this do not apply).

    This will produce a unlocked 1.1.2 and is suitable for the mixed 1.1.3 mode.


    Ah, there is also the infamous Zibri's anySIM for 1.1.3. Some claim it works, but..... draw your own conclusions.

  5. #5
    Newbie Array

    Join Date
    Jan 2008
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Aviegas,

    Thanks for your info. However, the IPSF-style unlock on 3.9 requires running a script on every reboot when running 1.1.3. The new unlock (basically a SW BL 4.6 circumvention method) doesn't seem to suffer from this problem (as far as I can tell). So does it use yet another method for unlocking?


  6. #6
    Newbie Array

    Join Date
    Jan 2008
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    <thinking mode>
    Sorry, I didn't read your post thoroughly enough it seems. So if I get it right, the new 4.6 unlock only offers the "mixed" 1.1.3 option (1.1.3 with 1.1.2 baseband)? That would explain the lack of reboot-issues. I'll try to coordinate my hands with my brain next time :-)
    </thinking mode>

  7. #7
    Professional Array

    Join Date
    Oct 2007
    Posts
    98
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    Quote Originally Posted by atomicster View Post
    Aviegas,

    Thanks for your info. However, the IPSF-style unlock on 3.9 requires running a script on every reboot when running 1.1.3. The new unlock (basically a SW BL 4.6 circumvention method) doesn't seem to suffer from this problem (as far as I can tell). So does it use yet another method for unlocking?
    Well, if I'm not toally wrong, the 4.6 Hack unlockes the baseband of 1.1.2, not 1.1.3 - so you can't compare. You can only upgrade the 'main os' to 1.1.3 with that hack, not the baseband. That's why you don't need that script.

  8. #8
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    260
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    20

    Default

    Quote Originally Posted by sirdir View Post
    Well, if I'm not toally wrong, the 4.6 Hack unlockes the baseband of 1.1.2, not 1.1.3 - so you can't compare. You can only upgrade the 'main os' to 1.1.3 with that hack, not the baseband. That's why you don't need that script.
    that wouldnt make sense as it is clearly stated that this unlock works for 1.1.3 otb iPhones. which will have the latest baseband anyway no matter what you try, as for there is no baseband downgrader at the moment.

  9. #9
    Professional Array

    Join Date
    Jul 2007
    Posts
    54
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Default

    Sirdir is correct. While OTB 1.1.3 is unlockable, it is only done by downgrading the modem firmware to the 1.1.2 level and then unlocking that. (has nothing to do with baseband, as both are at 4.6) The modem firmware of 1.1.3 is not currently unlockable, not until 1.1.4 comes out so the secpack can be analyzed (or something like that ). If you have a 1.1.3, your phone's modem firmware will be downgraded to 1.1.2. You can then upgrade the O.S. firmware back to 1.1.3, but you will still have the 1.1.2 modem firmware.

    That is how I understand it.


    Quote:
    Originally Posted by sirdir
    Well, if I'm not toally wrong, the 4.6 Hack unlockes the baseband of 1.1.2, not 1.1.3 - so you can't compare. You can only upgrade the 'main os' to 1.1.3 with that hack, not the baseband. That's why you don't need that script.

    that wouldnt make sense as it is clearly stated that this unlock works for 1.1.3 otb iPhones. which will have the latest baseband anyway no matter what you try, as for there is no baseband downgrader at the moment.

  10. #10
    Advanced Array Stefidar's Avatar

    Join Date
    Jan 2008
    Posts
    36
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    It wouldn't make sense but it's the truth.
    I have a week 50 4.6 OTB 1.1.2 phone, I restored to 1.1.3 through iTunes,
    DFUed, downgraded to 1.1.1, jailbreaked, updated to 1.1.2, (still having 4.03.13 baseband, and the moment I ran Geohot's unlock my baseband unlocked yes but now is 4.02 (the 1.1.2 one).
    So even if I softupgrade to 1.1.3 I am still going to be in hybrid mode which causes a lot of problems.
    When I tried to run the command with the 4.03.13 fls, it always produced an error.
    While in 1.1.3, when I try to update the baseband to 4.03 the phone gets relocked, and when I use the iClarified script or the ModmyIfone script it always unlocks to 4.02 instead.


 

 

Similar Threads

  1. [05.11.07] Looks like geohot got it again re unlock!
    By me. in forum Blacksn0w (3G(S) unlock)
    Replies: 10
    Last Post: 11-01-2009, 02:53 AM
  2. Geohot unlock 1.1.2 OTB - no Wi-Fi
    By tiborisimo in forum iPhone "2G" (Rev. 1)
    Replies: 20
    Last Post: 02-13-2008, 03:28 AM
  3. Is there a Geohot unlock for 3.9BL???
    By djpav in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 02-11-2008, 02:45 PM
  4. Geohot's New 1.1.2 Sw Unlock
    By blackthought in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 02-09-2008, 04:32 AM
  5. Geohot did it.. (hardware unlock)
    By bugout in forum General
    Replies: 192
    Last Post: 08-24-2007, 05:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:15 PM.
twitter, follow us!