Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39
Discuss EDGE Menu missing... at the iPhone "2G" (Rev. 1) - Hackint0sh.org; where is preferences.plist file?...
  1. #11
    Rookie Array

    Join Date
    Sep 2007
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    where is preferences.plist file?


  2. #12
    Newbie Array

    Join Date
    Sep 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Here you go:

    I am assuming that you have access to the files on the phone (via SSH or some other method,) and you know how to copy a file off of the phone and edit it.

    File that needs to be changed:
    /private/var/root/Library/Preferences/SystemConfiguration/preferences.plist

    I used Cyberduck to copy the file to my mac, then edited it on my mac using VI.

    Find this section in the file:

    <dict>
    <key>apn</key>
    <string>wap.cingular</string>
    <key>password</key>
    <string>CINGULAR1</string>
    <key>username</key>
    <string>WAP@CINGULARGPRS.COM</string>
    </dict>

    Change it to:

    <dict>
    <key>apn</key>
    <string>proxy</string>
    <key>password</key>
    <string></string>
    <key>username</key>
    <string></string>
    </dict>

    Save the file, and copy it back to the phone...
    --you could also SSH to the phone and use VI locally on the phone and change the file.

    Let me know if you need any more detail...

  3. #13
    Rookie Array

    Join Date
    Jul 2007
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    That's great, and I actually figured out that much on my own. But we need to go further to get it working with the old "mmode" "WAP".

    On a previous phone that ran windows mobile smartphone, this involved creating a proxy to the internet, where the proxy was connected to WAP at 10.250.250.54:8080, type HTTP, no username or password. You then built a GPRS on top of proxy (literally blank except for "proxy"), and you were done.

    How do you make this phone do that?

  4. #14
    Rookie Array

    Join Date
    Sep 2007
    Posts
    23
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Malefactor, I must admid that the instruction is a more technical than i can handle, but I am in the sam situation as you are. an old AT&T MMode data plan. Should we figure out how to turn this is on, please post your result.

    Thanks

  5. #15
    Rookie Array

    Join Date
    Sep 2007
    Posts
    23
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Malefactor, I must admid that the instruction is a more technical than i can handle, but I am in the same situation as you are; an old AT&T MMode data plan. Should we figure out how to turn this is on, please post your result.

    Thanks


  6. #16
    Rookie Array

    Join Date
    Sep 2007
    Posts
    23
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Malefactor, I must admid that the instruction is a more technical than i can handle, but I am in the same situation as you are; an old AT&T MMode data plan. Should we figure out how to turn this is on, please post your result.

    Thanks

  7. #17
    Newbie Array

    Join Date
    Sep 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have an original mmode unlimited data plan with the old ATT charter plan.
    Changing the APN to proxy allows everything to work on my phone...

    Am I missing something? What is different between proxy, mmode, and wap?

    I seem to remember reading something about this years ago...

  8. #18
    Newbie Array

    Join Date
    Sep 2007
    Location
    Honolulu, HI
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have the same prob, I have a old cingular sim.
    All white w/ orange 20 digits.

    I will try and let you know...

    Otherwise I am selling an unlocked phone and going back to my Java gmail app b/c it works!

  9. #19
    Rookie Array

    Join Date
    Sep 2007
    Posts
    23
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    D1V3t, I am glad to see a few old MMode people are still around. I am not familiar with your instruction, is there a another way to locate the Plist file, and edit the file.

    I used putty last night to unlcuk my phone. is that something I should use? Is teh Plist file is on my phone?

    Thanks,

  10. #20
    Newbie Array

    Join Date
    Sep 2007
    Location
    Honolulu, HI
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    So, it didn't work...

    This is what I tried:

    using ibrickr I d/led and edited the pref file

    the file has 181 lines to it.... and 2 places where it specifies apn

    First looks like voicmail settings:

    <code>
    <dict>
    <key>apn</key>
    <string>acds.voicemail</string>
    <key>password</key>
    <string></string>
    <key>username</key>
    <string></string>
    </dict>
    </code>

    Second I lost the originals but this is what I changed to:

    <code>
    <dict>
    <key>Interface</key>
    <dict>
    <key>DeviceName</key>
    <string>ip1</string>
    <key>Hardware</key>
    <string>com.apple.CommCenter</string>
    <key>Type</key>
    <string>com.apple.CommCenter</string>
    </dict>
    <key>com.apple.CommCenter</key>
    <dict>
    <key>AllowNetworkAccess</key>
    <integer>1</integer>
    <key>Available</key>
    <integer>1</integer>
    <key>Setup</key>
    <dict>
    <key>apn</key>
    <string>66.209.11.61</string>
    <key>CINGULAR1</key>
    <string></string>
    <key>WAP@CINGULAR.COM</key>
    <string></string>
    </dict>
    <key>Version</key>
    <integer>1</integer>
    </dict>
    </dict>
    </code>

    It didn't work, I am sure I can mess with the settings but I am a little busy now....

    I hope it helps find a solution


 

 
Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. [2.1] [edge] Missing Edge menu in setting's
    By isawugoing in forum General
    Replies: 1
    Last Post: 01-10-2009, 11:54 AM
  2. Missing EDGE menu - Ireland
    By Cerebro in forum iPhone "2G" (Rev. 1)
    Replies: 8
    Last Post: 05-17-2008, 11:31 PM
  3. Missing EDGE Menu FIXED!! mac guide for now!
    By Cerebro in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 03-20-2008, 09:06 AM
  4. [1.1.4 (1.1.3 OTB) ][Problem] No EDGE Menu
    By sho in forum iPhone "2G" (Rev. 1)
    Replies: 4
    Last Post: 03-16-2008, 08:02 PM
  5. [Missing] Countries on the Contacts Menu
    By footsie77 in forum Free Toolchain Software (Cydia App's)
    Replies: 6
    Last Post: 01-25-2008, 01:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 06:14 AM.
twitter, follow us!