Results 1 to 2 of 2
Discuss EDGE etc on any O2 SIM at the iPhone "2G" (Rev. 1) - Hackint0sh.org; I'd like to follow the procedures outlined in o2ukjailbreak to enable edge and visual voicemail ...
  1. #1
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    252
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default EDGE etc on any O2 SIM

    I'd like to follow the procedures outlined in o2ukjailbreak to enable edge and visual voicemail on my pay as you go SIM. This seems to involve changing some files on the iPhone. How could this be reversed? Because eventually will want to use my T Mobile contract SIM. Or could the settings easily be changed again for T Mobile?



  2. #2
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    252
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Feeling adventurous, I went ahead without further ado and followed the o2ukjailbreak instructions. I had already activated and jailbroke my 1.1.2 UK phone, and it's all working, on 1.1.2.

    I entered these commands:

    rm /var/root/Library/Preferences/com.apple.carrier.plist

    ln -s /System/Library/Frameworks/CoreTelephony.framework/Support/O2_UK.plist /var/root/Library/Preferences/com.apple.carrier.plist

    rm -f /var/root/Library/Preferences/SystemConfiguration/preferences.plist

    Then re-booted. The first visible change is that the E (EDGE) symbol has been replaced by a solid block.
    When trying to connect to the internet via Safari, I get the message "Could not activate EDGE: You are not subscribed to EDGE". As far as I know, I am though (I use an O2 Pay as you go, with unlimited Internet bolt on).
    Also, the visual voicemail does not work; I can only access my voicemail the normal way. I don't even know how visual voicemail looks like, of course.

    So I guess something has gone wrong somewhere. I'd be ever so grateful for any hints!

 

 

Similar Threads

  1. MacNN: iPhone '5G' case shows edge-to-edge screen, moved flash
    By hackint0sh in forum Latest Headlines
    Replies: 0
    Last Post: 05-14-2011, 04:50 PM
  2. Replies: 0
    Last Post: 03-11-2011, 02:20 PM
  3. Replies: 0
    Last Post: 02-26-2011, 06:10 PM
  4. Replies: 0
    Last Post: 02-13-2011, 11:20 PM
  5. Replies: 0
    Last Post: 02-13-2011, 10:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:10 PM.
twitter, follow us!