"Will this work with OTB 1.1.2 USA ? (bootloader 4.6) ??"

its not possible yet to downgrade baseband with new bootloader