Stop messing with old firmwares and just go up to 1.1.4!
Do a restore and just use iPlus.