Results 1 to 5 of 5
Discuss [Curious] Bootloader 101 Needed at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Here is what I know: The original 3.9BL allowed unlocking. How? Then came a newer ...
  1. #1
    Professional Array

    Join Date
    Jan 2008
    Posts
    57
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Default [Curious] Bootloader 101 Needed

    Here is what I know:

    The original 3.9BL allowed unlocking. How?

    Then came a newer 4.6BL that could not be unlocked until geohot's miracle.

    I was using iPlus to unlock and downgrade my 4.6BL to 3.9FB. I had the seemingly standard problem where I had to run through it twice.

    When I restored the 1.1.4 after having the 3.9FB I noticed that even though the phone was still not activated or jailbroken, I could see the phone was unlocked because it connected to T-Mobile.

    So, how was that possible?

    Why is the 3.9FB or regular 3.9BL safer to have than the 4.6BL if either can be unlocked? (know the 3.9 is desirable to keep the BB matching the firmware)



  2. #2
    Ninja Hack Array )law('s Avatar

    Join Date
    Mar 2008
    Location
    Some girls house...
    Posts
    3,325
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    194

    Default

    beacuse 3.9 is old territory and is more familer than 4.6 thats plus ziphone had a nasty habbit of downgrading bootloaders so that was also put in places so that people could downgrade safely if they wanted and upgrade when a way becomes available, read the iplus sticky for more info
    Playstaion 3 gamer tag HackNinjaLaw

    Off the scene till i get a new lcd or a new iphone

  3. #3
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    419
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yeah i am on original 3.9 and when i restorted to 1.1.4 it was still unlocked but it wasnt jailbroken.

  4. #4
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    another good reading on BL here

  5. #5
    Senior Professional Array libertybenz2's Avatar

    Join Date
    Jan 2008
    Location
    New Jersey
    Posts
    253
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    26

    Default

    dude..

    its very much possible if u didnt virginize. For example, i start off on 1.0.2 and virginize then run anysim. Even if i upgrade back to w.e. version, it will still have the changes made by anysim, and vice versa. IF i downgrade to 1.1.1. or 1.0.2 i will still be unlocked, unless u truly erase the bL and reapply the unlock


 

 

Similar Threads

  1. iPhone 3G Firmware 2.2 Baseband 2.30.00 Bootloader 5.9 Unlock Needed
    By zeeshansohail in forum Yellowsn0w (3G unlock)
    Replies: 22
    Last Post: 06-22-2009, 05:39 AM
  2. 4.6 bootloader needed!!
    By skatas in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 02-08-2008, 07:20 PM
  3. Sub- Forum Needed For New Bootloader 4.6
    By car__34 in forum iPhone "2G" (Rev. 1)
    Replies: 6
    Last Post: 11-17-2007, 12:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:23 AM.
twitter, follow us!