Heres my story. I have an OTB 1.1.1 iphone. I downgraded it to 1.0.2 with ibrickr and avtivated it with wiNstallerGUI. Unlock it with anysim 1.1

Now let say, for some reasons, I want to upgrade it back to 1.1.1 and unlock it again. If I upgrade it to 1.1.1, will my iphone be locked/bricked? If that happened, can I downgrade it back to 1.0.2 and use anysim 1.1 to unlock it? Thanks a bunch.