Quote Originally Posted by dunga View Post
How can I know my bootloader version? I bought it as a 1.1.1... but upgraded to 1.1.2 and it's now locked... I manage to jailbreak but the anysim doesn't work.

I keep reading people unlocking an "original 1.1.1" but using independence that is for Mac.
you need to downgrade to 1.1.1,

then do this:

http://www.hackint0sh.org/forum/showthread.php?t=16398

hope that helps