Page 3 of 23 FirstFirst 12345678910111213 ... LastLast
Results 21 to 30 of 221
Discuss [Bootloader] Anyway to downgrade from 4.6 to 3.9? at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Originally Posted by car__34 has anyone tried flashing the bootloader... I did try (knowing that ...
  1. #21
    Professional Array

    Join Date
    Oct 2007
    Posts
    63
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    Quote Originally Posted by car__34 View Post
    has anyone tried flashing the bootloader... I did try (knowing that I might've bricked the phone totally) and it just hangs.. same way as if you were trying to flash the baseband..
    I didn't try to flash the bootloader.
    I tried to flash the baseband firmware with bbupdate.
    It just tried to flash the firmware without success, it did not hang though.


  2. #22
    Senior Professional Array car__34's Avatar

    Join Date
    Jul 2007
    Posts
    208
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Unhappy

    exactly dosent let you bypass the boot..

  3. #23
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    156
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    Guys,

    Why do you keep trying to downgrade the baseband?? Even if you sucessfully fluked it, you still cant unlock it as anySIM still wont work with the new bootloader. You just risk damaging the phone by doing that!!

    @ Car__34

    Jesus man, that was dangerous!! What file did you try and reflash the bootloader with, the baseband Firmware??

  4. #24
    Professional Array

    Join Date
    Oct 2007
    Posts
    63
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    Quote Originally Posted by pspsully View Post
    Guys,

    Why do you keep trying to downgrade the baseband?? Even if you sucessfully fluked it, you still cant unlock it as anySIM still wont work with the new bootloader. You just risk damaging the phone by doing that!!

    @ Car__34

    Jesus man, that was dangerous!! What file did you try and reflash the bootloader with, the baseband Firmware??
    I tried to downgrade the baseband firmware on 4.6 bootloader when I first got my 1.1.2.
    I only did it once and then later I found out the new 4.6 thingy.

    Yeah, I don't know what car__34 was doing. Using bbupdate -l ?
    It probably can't do any damage to his phone.
    I really wish otherwise because that would mean we are in business, right? (Haha sorry car__34 ).

  5. #25
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    148
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    Quote Originally Posted by car__34 View Post
    has anyone tried flashing the bootloader... I did try (knowing that I might've bricked the phone totally) and it just hangs.. same way as if you were trying to flash the baseband..
    Yes, mbtec reflashed his 3.9 bootloader with bbupdater -l with the 3.9 .fls file (availble from the 1.0 firmware zip file). After that (if you do a bbupdater -v, it will respond with unsuccesful pinging), of course you need to reflash the firmware and eeprom with bbupdater -f ICE*.fls -e ICE*.eep. The phone was back to normal after that.

    So there is no problem reflashing the bootloader with an identical one.

    Can't we just reverse engineer bbupdater to skip and patch the signature checking (I would actually assume this is done on the bootloader, not bbupdater)? That is, it would just do its flashing ignoring whether the bootloader tells it it is not signed properly. Or maybe this would totally brick the phone?

    PmgR

    Inform yourself of the current human rights violations in China: check out some of the links in my footer:
    Last edited by PmgR; 11-20-2007 at 10:28 PM.
    =============================================
    Help stop the persecution of Falun Dafa in China!
    Stop organ harvesting from living people in China's labor camps
    http://www.faluninfo.net
    http://www.theepochtimes.com/211,111,,1.html
    =============================================
    Falun Dafa, an ancient Chinese self-cultivation practice,
    based on the principles of
    * Truthfulness * Compassion * Tolerance *
    http://www.falundafa.org
    =============================================


  6. #26
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    156
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    15

    Default

    Thks for that PmgR,

    i have just recieved the 3.9 bootloader fls file and am in two minds weather or not to try and reflash it on a 4.6 phone. I know it wont work as it will check if its newer but the temptation is there man!!!

    And there was me giving out that People where crazy for trying stuff that doesnt work lol!!

    You see, this is getting very very interesting now, we have the 3.9 bootloader .fls file, we know now how to implement it using bbupdater, all we need now is a way to either erase the current bootloader or overwrite it with the older version!!
    Last edited by pspsully; 11-20-2007 at 10:28 PM.

  7. #27
    Rookie Array

    Join Date
    Nov 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Where does the signature of the new firmware file get checked? If it is in baseband then we need a exploitable hole in baseband to circumvent the check. Next we would need the actual code to flash the loader, right?

  8. #28
    Newbie Array

    Join Date
    Oct 2007
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    My iphone after some restores said: Your bootlloader is too old.. upgrade to 1.8 or newer version.

    is it method to fix the problem? Upgrade bootloader? how to do that.

    Please help me.

  9. #29
    Advanced Array

    Join Date
    Oct 2007
    Posts
    49
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    @pspsully:
    could you send me the file too. PM me.

    I'm thinking hard about to use it
    What could happen???

    bbupdater is an apple tool, right? and the function -l wasn't coded for fun.
    So in my opinion its prgrammed to show an error if someone accidently wants to downgrade bootloader.
    So we could give it a try.

    Afterthat we could flash a new BB 1.0.2 on the phone in order to repair the bb and correcting the bootloader to 3.x
    ?!? hmh

  10. #30
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    148
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    Quote Originally Posted by pspsully View Post
    Thks for that PmgR,

    i have just recieved the 3.9 bootloader fls file and am in two minds weather or not to try and reflash it on a 4.6 phone. I know it wont work as it will check if its newer but the temptation is there man!!!

    And there was me giving out that People where crazy for trying stuff that doesnt work lol!!

    You see, this is getting very very interesting now, we have the 3.9 bootloader .fls file, we know now how to implement it using bbupdater, all we need now is a way to either erase the current bootloader or overwrite it with the older version!!
    Reflashing your 4.6 baseband with the 3.9 file will probably not work since it is a downgrade. bbupdater will probably come back with "can't verify flash image", the same if you try to reflash the firmware when it hasn't been erased with ieraser.

    Maybe you can find a way to patch bbupdater to reflash it anyway after the error.

    PmgR

    Inform yourself of the current human rights violations in China: check out some of the links in my footer:
    =============================================
    Help stop the persecution of Falun Dafa in China!
    Stop organ harvesting from living people in China's labor camps
    http://www.faluninfo.net
    http://www.theepochtimes.com/211,111,,1.html
    =============================================
    Falun Dafa, an ancient Chinese self-cultivation practice,
    based on the principles of
    * Truthfulness * Compassion * Tolerance *
    http://www.falundafa.org
    =============================================


 

 

Similar Threads

  1. downgrade bootloader
    By Claytod2 in forum iPhone 3G
    Replies: 1
    Last Post: 04-19-2010, 09:08 AM
  2. downgrade bootloader
    By Obelix_22 in forum iPhone 3G
    Replies: 1
    Last Post: 10-25-2009, 08:26 AM
  3. Replies: 6
    Last Post: 02-19-2008, 12:34 AM
  4. [OTB 1.1.3] Is downgrade bootloader necessary?
    By apsk121 in forum iPhone "2G" (Rev. 1)
    Replies: 4
    Last Post: 02-17-2008, 04:31 PM
  5. Replies: 1
    Last Post: 02-09-2008, 05:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 08:55 PM.
twitter, follow us!