Results 1 to 10 of 10
Discuss [BL3.9] Can JerrySIM upgrade back to 4.6 ? at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Please, I know this may look wrong place to post. But this is about the ...
  1. #1
    Advanced Array

    Join Date
    Dec 2007
    Posts
    44
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [BL3.9] Can JerrySIM upgrade back to 4.6 ?

    Please, I know this may look wrong place to post.
    But this is about the software upgrade (unwillingly downgrade) BL4.6 <--> BL3.9. So I think it's not wrong, not 100% right place though....


    I'm one of many people that blindly downgrade from BL4.6 --> BL3.9.
    Looks like before Geohotz discovered his exploits to play around with BL4.6, there was JerrySIM that make the same thing without physically openning iPhone.

    Is it possible to use the technique JerrySIM to fix what Ziphone did?????



  2. #2
    ale
    ale is offline
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    200
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Default

    I don't understand what the problem is and why you want to upgrade back. I downgraded the bootloader when I unlocked with ziphone and every single feature on my iPhone works perfect BTW: forget about Jerry sim, that project has been abandoned

  3. #3
    Professional Array jrui's Avatar

    Join Date
    Jan 2008
    Posts
    86
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    11

    Default

    The question here is,

    "the ability to upgrade back to 4.6BL if I want"

  4. #4
    ale
    ale is offline
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    200
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Default

    Quote Originally Posted by jrui View Post
    The question here is,

    "the ability to upgrade back to 4.6BL if I want"
    The other question is "what for?"

  5. #5
    Former Bender
    Guest

    Default

    For the people (especially legit AT&T users) who want to keep their warranty when Jailbreaking with Ziphone (When it has downgraded their 4.6BL to 3.9BL).


  6. #6
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default

    I think JerrySIM was an exploit of 4.6...

    Those on AT&T do not need to unlock, so they can stay with 4.6....

  7. #7
    Senior Professional Array jawnsixteen's Avatar

    Join Date
    Oct 2007
    Location
    Boston
    Posts
    151
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    I guarantee that there will soon be a way for people with 3.9 to upgrade the bootloader. You want to know why?

    To answer that, let me ask one more question:

    Would the hacking community forget about every person who bought there phone before 1.1.2?

    Everyone needs to wake the f up

  8. #8
    ale
    ale is offline
    Senior Professional Array

    Join Date
    Sep 2007
    Posts
    200
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Default

    Quote Originally Posted by XianLi View Post
    For the people (especially legit AT&T users) who want to keep their warranty when Jailbreaking with Ziphone (When it has downgraded their 4.6BL to 3.9BL).
    Good point, but you mean JUST legit AT&T users, as the warranty dies anyway if you do not officilally activate your iphone (that is, sign the expensive contract) within a short period after purchase (If i remember well its 6 weeks).
    Besides, with bl 3,9 every feature works properly, while with 4.6 and fm1.1.3 or 1.1.4 it does not

    Edit: if you use ziphone just for the jailbreak, (legit customer do not need to unlock, of course) it does not downgrade the bootloader, so the objection is pointless, actually
    Last edited by ale; 03-08-2008 at 03:03 PM.

  9. #9
    Board Hero Array

    Join Date
    Dec 2007
    Posts
    1,044
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    74

    Default

    Quote Originally Posted by jawnsixteen View Post
    I guarantee that there will soon be a way for people with 3.9 to upgrade the bootloader. You want to know why?

    To answer that, let me ask one more question:

    Would the hacking community forget about every person who bought there phone before 1.1.2?

    Everyone needs to wake the f up
    How do you know it will be soon? Unlock for the 4.6 BL took 3 months. And if there's no exploit in 3.9BL, there's no exploit in 3.9BL.
    iPhone 3GS / 3.1.2 JB (PwnageTool) / 04.26.08 carrier-locked, Carrier Logo Fixer / Cydia / 1000 posts on Hackint0sh

    Installing Cydia programs on a phone that has no internet connection: read this.

    Editing binary .plist, .strings, .nib and .xib files:
    * on your computer: Windows tool / conversion website.
    * on your iPhone: convert those files in a terminal with plutil (installed with Erica Utilities) or edit them with iFile (Cydia links).

  10. #10
    Senior Professional Array neonkoala's Avatar

    Join Date
    Jul 2006
    Posts
    277
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    23

    Default

    Quote Originally Posted by aviegas View Post
    I think JerrySIM was an exploit of 4.6...

    Those on AT&T do not need to unlock, so they can stay with 4.6....
    JerrySIM didn't depend on the bootloader it used an STK exploit. Read about it here: http://iphone-dev.org/news:jerry:leaked


 

 

Similar Threads

  1. [JerrySIM] JerrySIM is worth for the future iPhone...
    By Scienartist in forum Turbo-, Supersim and Simcloning Solution
    Replies: 16
    Last Post: 02-28-2008, 09:52 PM
  2. [ANNOUNCEMENT] JerrySIM: Almost software unlock solution
    By rchik in forum iPhone "2G" (Rev. 1)
    Replies: 52
    Last Post: 02-08-2008, 03:48 AM
  3. how to upgrade back to 1.1.1
    By wawawa11 in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 10-19-2007, 08:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:06 AM.
twitter, follow us!