Page 1 of 29 123456789101121 ... LastLast
Results 1 to 10 of 288
Discuss [BL3.9/BL4.6] Downgrade to 3.9 now, and software upgrade later ! at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Introducing BL3.9FakeBlank! Thanks to MuscleNerd, aCujo and geohot, it is now possible to software downgrade ...
  1. #1
    drg
    drg is offline
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    Canada
    Posts
    479
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Thumbs up [RELEASE: BL3.9FakeBlank] Downgrade to 3.9 now, and software upgrade later !

    Introducing BL3.9FakeBlank!

    Thanks to MuscleNerd, aCujo and geohot, it is now possible to software downgrade BL4.6 to BL3.9 and be fully software upgradeable later. Yes, you read right... the best of both worlds!

    Full tutorial:

    http://acujo.com/tutorials/how-to-do...software-only/

    Solor has put this together into a ramdisk hack:

    http://www.hackint0sh.org/forum/show...&postcount=159

    Those who are already at BL3.9 are still out-of-luck for now.

    Further reading:

    http://www.hackint0sh.org/forum/showthread.php?t=32309

    http://acujo.com/bootloaders/the-39-...cations-blank/

    http://iphone-dev.org/sgold_bootrom:fakeblank

    _______________________________________ EDIT

    Also introducing BL4.6FakeBlank !

    http://iphone-dev.org/sgold_bootrom:fakeblank46

    Same concept, except for 4.6
    Last edited by drg; 03-05-2008 at 02:43 PM.



  2. #2
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    352
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    confirmed working in to any direction, if you are on "original" 3.9 (aka zibri disaster or OOB), you need to use testpoint method to upgrade to 3.9fakeblank (or 4.6) after that everything can be done software way

  3. #3
    drg
    drg is offline
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    Canada
    Posts
    479
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    Solor, just to be sure, to re-upgrade to BL4.6 from within BL3.9fakeblank, all one needs to do is run

    iunew BL46NOR.bin

    Correct?

  4. #4
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    352
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    Quote Originally Posted by drg View Post
    Solor, just to be sure, to re-upgrade to BL4.6 from within BL3.9fakeblank, all one needs to do is run

    iunew BL46NOR.bin

    Correct?
    yes and ienew also

  5. #5
    Advanced Array

    Join Date
    Oct 2007
    Posts
    44
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I don't see the point to upgrade my BL to v.4.x. Why would i move it from a totally open and hackable BL 3.9 to a close and problematic BL 4.x?

    I don't see the point. Apple have to support both BL, i'm not at any risk to lose new functionality, so why would i do it?

    -hal9000mx


  6. #6
    Senior Professional Array

    Join Date
    Sep 2007
    Location
    Germany, Europe :)
    Posts
    199
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    17

    Default

    hal:
    3.9 is quite open and hackable exept for the fact that it doesnt allow to arbitrary upgrade the BL !

    So if e.g. Geohot composes a BL that can unlock at a lower leverl or do whatever magic the 3.9 people are lost.

    So while it doesnt make too much sense to upgrade 3.9 to 4.6 it makes *lot* of sense to downgrade from a 4.6 to a 3.9_blanked if you want to downgrade at all because then you are not in that trap that 3.9 BL people are ( okay, a trap that may never triggers ).

    Greetings,

    Ender

    P.S. requesting zibri: please dgrade to 3.9_blanked instead to original 3.9 in next ziphone version !!!

  7. #7
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    129
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    13

    Default

    i'm a OTB 1.1.2 user with BL 4.6

    i downgraded to 3.9 and now have 1.1.4 with 04.05 baseband

    i wonder , am i taking the full advantage of the new baseband or am i using a old but patched baseband ?

    to be more clear , if apple did smt to improve signal etc in the new baseband , am i getting it now ?

  8. #8
    drg
    drg is offline
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    Canada
    Posts
    479
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    Quote Originally Posted by enderffx View Post
    hal:
    3.9 is quite open and hackable exept for the fact that it doesnt allow to arbitrary upgrade the BL !

    So if e.g. Geohot composes a BL that can unlock at a lower leverl or do whatever magic the 3.9 people are lost.

    So while it doesnt make too much sense to upgrade 3.9 to 4.6 it makes *lot* of sense to downgrade from a 4.6 to a 3.9_blanked if you want to downgrade at all because then you are not in that trap that 3.9 BL people are ( okay, a trap that may never triggers ).
    100% agree... BL3.9 makes sense now, but it is nice to know that I can SW upgrade to BL4.6_geomod when it comes out

  9. #9
    Advanced Array

    Join Date
    Oct 2007
    Posts
    44
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by enderffx View Post
    hal:
    3.9 is quite open and hackable exept for the fact that it doesnt allow to arbitrary upgrade the BL !

    So if e.g. Geohot composes a BL that can unlock at a lower leverl or do whatever magic the 3.9 people are lost.

    So while it doesnt make too much sense to upgrade 3.9 to 4.6 it makes *lot* of sense to downgrade from a 4.6 to a 3.9_blanked if you want to downgrade at all because then you are not in that trap that 3.9 BL people are ( okay, a trap that may never triggers ).

    Greetings,

    Ender

    P.S. requesting zibri: please dgrade to 3.9_blanked instead to original 3.9 in next ziphone version !!!
    I don't know why, but i have this felling that when BL 4.x worth the upgrade, there will be a way to upgrade it.

    Maybe it's just me, but i think that is there is a way to going down, there will be a way to going up too. The difference is the need, BL 3.9 is far better than 4.x, that's why we have a way to going from 4.x to 3.9. And i'm pretty sure that when a new BL would be better than 3.9 there will be a way to movien up.

    -hal9000mx

  10. #10
    drg
    drg is offline
    Senior Professional Array

    Join Date
    Oct 2007
    Location
    Canada
    Posts
    479
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    This is the best of both worlds.

    Have 3.9 now and be SW upgradeable.

    There is no downside to BL3.9FakeBlank !


 

 
Page 1 of 29 123456789101121 ... LastLast

LinkBacks (?)

  1. 03-26-2010, 02:56 PM
  2. 03-20-2010, 10:15 PM
  3. 02-07-2009, 11:05 AM

Similar Threads

  1. 3GS AND 3G upgrade to 4.0 --- want to downgrade to 3.1
    By jbarcarse in forum Spirit (jailbreak)
    Replies: 7
    Last Post: 07-07-2010, 05:45 PM
  2. Replies: 1
    Last Post: 02-13-2008, 07:16 AM
  3. Replies: 2
    Last Post: 02-02-2008, 12:47 PM
  4. OTB 1.1.2 H/W downgrade gone bad(software part), no BB.
    By ericjarvies in forum iPhone "2G" (Rev. 1)
    Replies: 10
    Last Post: 01-27-2008, 07:06 PM
  5. Replies: 0
    Last Post: 11-09-2007, 06:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:00 PM.
twitter, follow us!