Hi, this is my story, a week ago I receive two 1.1.1 iPhones, I downgraded/activated/updated/unlocked both with success with Independence 1.2.3 and Anysim 1.1, all was working fine, so I give one of them to my father, but he press by error the RESTORE button on his iTunes, before the restore the iPhone is back to "Activate with iTunes screen" then I open Independence and show me that I have to downgrade to the 1.0.2 so I do it, all the processes was fine (Downgrade/Activation/Jailbreak/SSH... etc) but before the re-update Independence show me the "Downgrade to 1.0.2 to activate" message, the app doesn't allow me to activate again on 1.1.1!!!!

Also on my other iPhone I have a random "THIS ACCESSORY IS NOT MADE TO WORK WITH IPHONE", and nothing is attached to the iPhone, what is wrong???

Thank you and sorry for my english

Mac0S X 10.4.10