Page 1 of 2 12 LastLast
Results 1 to 10 of 16
Discuss [Baseband] Repair needed, 4.6 M3S2 BL at the iPhone "2G" (Rev. 1) - Hackint0sh.org; I have an iPhone currently on 1.1.4, I know nothing of the history, only that ...
  1. #1
    Rookie Array

    Join Date
    Oct 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [Baseband] Repair needed, 4.6 M3S2 BL

    I have an iPhone currently on 1.1.4, I know nothing of the history, only that it wasn't hardware unlocked. restore to 114 throws 1011. "Needs repair" message. iLiberty can jailbreak+activate without problem. I've downgraded to to 111, this does not help.

    I can get ieraser to run with a secpack from 040313. When it does run, I get:

    PHP Code:
    Waiting for data...

    Got Header77 0b cc
    02 00 85 00 02 00 FF 85 02 03 00
    SECPACK
    02 00 04 02 06 00 01 00 00 00 00 00 0B 02 03 00
    02 00 02 08 06 00 00 00 00 00 00 00 0B 08 03 00

    Erase
    02 00 05 08 02 00 00 00 07 08 03 00
    02 00 06 08 06 00 01 00 00 00 0A 00 AD 08 03 00
    Hopefully the main flash was erased
    wait for next step.... 
    In previous attempts I was able to get many more lines under "Erase". Is this running as it should?

    Later, when I try to flash, I get:
    PHP Code:
    ./bbupdater -f ICE03.14.08_G.fls -e ICE03.14.08_G.eep

    ProcessDetailUpdated
    Boot-loader is active
    ProcessDetailUpdated
    EBL version4.6 M3S2 4..6
    ProcessDetailUpdated
    Boot mode isCC
    ProcessDetailUpdated
    Baud rate set to 750000
    ProcessDetailUpdated
    Get flash id.
    ProcessDetailUpdatedCFI stage 1
    ProcessDetailUpdated
    Flash ID is88620089
    ProcessDetailUpdated
    CFI stage 2
    ProcessDetailUpdated
    Boot process finished
    ProcessOutlineUpdated
    Reading SW version data
    ProcessDetailUpdated
    Receiving data
    ProcessOutlineUpdated
    Process time was 10.0 sec
    Upgrade from a
    to
    Downloading EEP
    ProcessOutlineUpdated
    Start downloading from file IC03.14.08_G.eep
    ProcessDetailUpdated
    Sending sec-pack.
    ProcessDetailUpdatedLoading region 0
    ProcessDetailUpdated
    Sending end-pack
    ProcessOutlineUpdated
    Process time was 1815 msec.
    ErrorFailed to download .EEPCould not verify downloaded image.
        
    firmware01.00 G
      eep version
    01.00
    eep revision
    01.00
      bootloader
    01.00 M1S1
    Preparing to flash using 
    /dev/tty.baseband at 750000 baud
    Please reset target
    Resetting target
    ...
    ProcessOutlineUpdatedProcess time was 10.0sec.
    Retry attempt 1
    Resetting target
    ... 
    All the way to 10... and then error "baseband bootloader is too old".

    I get the same 10 retries and same error when I try to flash the bootloader via

    bbupdater -l BOOT03.09_M3S2.fls

    Any ideas? Which secpack should I use? secpack040313-113 is the only one that seems to work at all.

    Thanks



  2. #2
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Wow.
    what's going on?
    You restored 1.1.4 then get 1011 error. Is that when you decide to downgrade to 1.1.1? Why ?
    Was the phone working before you restore to 1.1.4 ?
    Do you know what you are doing? If you are not sure, stop before you make it worse ... I'm no expert here but seeing what you did I'm shocked.

  3. #3
    Rookie Array

    Join Date
    Oct 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    No, it was not working obviously, otherwise I would not have done anything to it.

    Rest assured 111 downgrade was only on the 3rd solid day of attempts it wasn't my first random attempt.

    I am beginning to think there may be physical damage to the device. Sometimes, I can "ierase" other times i cannot, i have to retry many times to get it to work. Sometimes, 114 restore works (but with 1011, stuck in restore mode of course), other times it throws 1604, reboot try again, it works.

    iLiberty seems to give me most consistent results in jailbreaking / activating / installing stuff. However, bootneuter hasn't worked once. Sometimes it shows the BL status. Most recently it showed 3.9 fakeblank. I chose 4.6/neuter/unlock but it froze (30 min) at "flashing bootloader". Now bootneuter hangs indefinitely at "determining current settings".

  4. #4
    Newbie Array

    Join Date
    Jan 2008
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default 1.1.4

    ive got a 1.1.4 iphone OOB and i was wondering whether i need to downgrade the bootloaded to 3.9 or leave it as 4.6 im so confused please help

  5. #5
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by enry View Post
    No, it was not working obviously, otherwise I would not have done anything to it.

    Rest assured 111 downgrade was only on the 3rd solid day of attempts it wasn't my first random attempt.

    I am beginning to think there may be physical damage to the device. Sometimes, I can "ierase" other times i cannot, i have to retry many times to get it to work. Sometimes, 114 restore works (but with 1011, stuck in restore mode of course), other times it throws 1604, reboot try again, it works.

    iLiberty seems to give me most consistent results in jailbreaking / activating / installing stuff. However, bootneuter hasn't worked once. Sometimes it shows the BL status. Most recently it showed 3.9 fakeblank. I chose 4.6/neuter/unlock but it froze (30 min) at "flashing bootloader". Now bootneuter hangs indefinitely at "determining current settings".
    so what fw is on your phone now.
    you know that bootneuter works only on 1.1.4 right? and you may need bsd on the phone as well.
    Let us know what you have


  6. #6
    Senior Professional Array

    Join Date
    Oct 2007
    Posts
    186
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    i think it is a time to post some sticky about this 1011 error. So, people can read it before doing something like this (am i right dtube). Look like we have so many pp with an 1011 error!!!

    Here the trick: Update back to 1.1.4 (if you want to be safe, DFU mode and do the restore and update 2 time....). Down load pwnage tool (win/mac) and pwnage your phone then let's pwnage tool reflash your bl and bb.....After that everything should work. If you have any question about pwnage (where to get it and how to get it and stufff....) Head to the Pwnage tool section. Good Luck

  7. #7
    Rookie Array

    Join Date
    Oct 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    OK tinhbantown I will try. Thanks.

  8. #8
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Well...
    I'm not sure about the sticky
    I don't think there is a simple "one for all" for 1011 error.
    There are cases where flashing BB and BL failed. In such case, what's next?

    You refer to pwning the phone to reflash BL + BB. I take it that you meant baseband BL right?; and in that case you meant bootneuter right?.

    Pwnage has nothing to do with baseband. It deals with the OS bootloader only.
    So if you are referring to baseband then it's bootneuter.
    If it's bootneuter, you don't need to pwned the phone.
    The requirement for bootneuter is to have 1.1.4

    If you are saying to use pwnage so you can customize the 1.1.4 fw with bootneuter then that's one way of getting the bootnetuer onto the phone. I think I understand why you mentioned pwnage now. But again, iLiberty+ can delivered the bootneuter to the phone so you don't have to pwned it.
    Last edited by dtube; 05-09-2008 at 08:41 AM.

  9. #9
    Rookie Array

    Join Date
    Oct 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dtube View Post
    so what fw is on your phone now.
    you know that bootneuter works only on 1.1.4 right? and you may need bsd on the phone as well.
    Let us know what you have
    I have 114 and blcheck reports 3.9 M3S2. bbupdater -v doesn't report anything (no baseband).

    I'll DFU restore to 114 (twice as suggested) and report back.

  10. #10
    Rookie Array

    Join Date
    Oct 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by dtube View Post
    Well...
    You refer to pwning the phone to reflash BL + BB. I take it that you meant baseband BL right?; and in that case you meant bootneuter right?.

    Pwnage has nothing to do with baseband. It deals with the OS bootloader only.
    So if you are referring to baseband then it's bootneuter.
    If it's bootneuter, you don't need to pwned the phone.
    The requirement for bootneuter is to have 1.1.4

    If you are saying to use pwnage so you can customize the 1.1.4 fw with bootneuter then that's one way of getting the bootnetuer onto the phone. I think I understand why you mentioned pwnage now.
    I don't care about pwnage. I am very happy just using iLiberty to unlock/activate/unlock.

    Bootneuter says I have 3.9, not neuter not fake blank. This sounds right. If I restore to 114, unlock, activate, install BSD & bootneuter (through iLiberty), when I try to neuter, or unlock, it hangs eternally at "flashing bootloader".

    For example, I started a DFU restore to 114 15 min ago. It's been @ "Restoring iPhone Firmware" for 10 minutes. It will certainly throw a 1011 or 1002.

    BTW - Now, if I run ieraser/ienew manually, I get:

    PHP Code:
    Waiting for data...

    Got Header77 0b cc
    02 00 85 00 02 00 FF 85 02 03 00
    SECPACK

    Erase 
    Instead of those hex numbers I get empty lines, (LOTS AND LOTS OF THEM) and the process never ends.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 43
    Last Post: 05-02-2008, 09:21 AM
  2. [SOLUTION]Broken 04.03.13 Baseband - Repair Needed
    By Kael008 in forum iPhone "2G" (Rev. 1)
    Replies: 2
    Last Post: 02-11-2008, 06:27 PM
  3. Replies: 1
    Last Post: 01-31-2008, 12:22 AM
  4. "Repair Needed", no WiFi, baseband screwed, monetary reward!
    By ogs1 in forum iPhone "2G" (Rev. 1)
    Replies: 26
    Last Post: 12-13-2007, 07:28 PM
  5. Repair Needed, Missing Baseband, NO WIFI - I got it fixed
    By vermsky in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 11-09-2007, 08:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:03 PM.
twitter, follow us!