Page 1 of 2 12 LastLast
Results 1 to 10 of 11
Discuss [All FW] Incorrect SIM at the iPhone "2G" (Rev. 1) - Hackint0sh.org; I tried all firmware version, except for 1.1.4, all the other versions will show a ...
  1. #1
    Rookie Array

    Join Date
    Jan 2008
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Unhappy [All FW] Incorrect SIM

    I tried all firmware version, except for 1.1.4, all the other versions will show a dialog of 'incorrect sim, please insert a unlocked or valid sim card to activate', no matter the orignal sim or at&t sim I tried.

    Any idea to repair this problem? I have tried refurbish with Ziphone 2.5c, also tried erase baseband, verginzer etc.....

    P.S. it is currently BL3.9



  2. #2
    Ninja Hack Array )law('s Avatar

    Join Date
    Mar 2008
    Location
    Some girls house...
    Posts
    3,325
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    194

    Default

    you try anysim also why no 1.1.4?
    Playstaion 3 gamer tag HackNinjaLaw

    Off the scene till i get a new lcd or a new iphone

  3. #3
    Rookie Array

    Join Date
    Jan 2008
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Unhappy

    Quote Originally Posted by )law( View Post
    you try anysim also why no 1.1.4?
    I have tried Anysim, doesn't work. Actually even before unlock, jusr immediately after restoration, it shows incorrect SIM, not related to unlock or activation. It seems my iphone simply doesn't recognize any sim I inserted as valid for activation.

    The reason I don't what 1.1.4 is that my wifi only works for low version, for 1.1.4 I cannot join any network through iphone's wifi, and then no way to install softwares

    Please help~~

  4. #4
    Ninja Hack Array )law('s Avatar

    Join Date
    Mar 2008
    Location
    Some girls house...
    Posts
    3,325
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    194

    Default

    oh man this sounds bad, sounds like you tried a lot of things, do you get any errors while restoring in itunes also?
    Playstaion 3 gamer tag HackNinjaLaw

    Off the scene till i get a new lcd or a new iphone

  5. #5
    Solt
    Guest

    Default

    Well you should detect your iPhone as NEW after restore.... And about incorrect sim,it may be a hardware problem...


  6. #6
    Rookie Array

    Join Date
    Jan 2008
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yes, different errors, sometime 1101, sometim 1105, sometimes 16x4 cant remember, but most time it restores smoothly with correct counting down to reboot dialog shows.

    but after the reboot, when iTunes try to show activation interface, instead it shows I need to insert an unlocked SIM or valid SIM to activate.

    Bad luck, I had this kind of problem before for some other iphone, but easy to get rid of by restoration, but this time, any restoration other than 1.1.4 won't work, and only 1.0.2 can connect to wifi correctly, others just showing 'unable to join the network'

  7. #7
    Senior Professional Array

    Join Date
    Jan 2008
    Posts
    111
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    How would you know if 1.1.4 doesn't work without trying it? And how do you know your wifi has any problems on 1.1.4?

    If all else fails, restore to factory and take it back to apple with the AT&T sim in it... they should exchange it

  8. #8
    Rookie Array

    Join Date
    Jan 2008
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Unhappy

    Quote Originally Posted by enkrypt3d View Post
    How would you know if 1.1.4 doesn't work without trying it? And how do you know your wifi has any problems on 1.1.4?

    If all else fails, restore to factory and take it back to apple with the AT&T sim in it... they should exchange it
    I tried 1.1.4 so I know 1.1.4 will not give incorrect sim warning, and can be successfully j/a/u-ed, but only problem as I said, it cannot connect to wifi although it can find several wifi signals.

    only 1.0.2 can connect to wifi, this is very strange to me, it seems the hardware is good, but fw version DOES affect the wifi module, how can it be? and 1.0.2 will give incorrect sim dialog. sucks

    If I want to exchange it, they will definitely first ask me to show them the problem, how? the will recommend me to restore it to 1.1.4, and 1.1.4 will have no incorrect sim issue, at the same time, before activation I cannot show them the wifi proble,

    any suggestion?

  9. #9
    Senior Professional Array

    Join Date
    Jan 2008
    Posts
    111
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    18

    Default

    Quote Originally Posted by godspeedchu View Post
    I tried 1.1.4 so I know 1.1.4 will not give incorrect sim warning, and can be successfully j/a/u-ed, but only problem as I said, it cannot connect to wifi although it can find several wifi signals.

    only 1.0.2 can connect to wifi, this is very strange to me, it seems the hardware is good, but fw version DOES affect the wifi module, how can it be? and 1.0.2 will give incorrect sim dialog. sucks

    If I want to exchange it, they will definitely first ask me to show them the problem, how? the will recommend me to restore it to 1.1.4, and 1.1.4 will have no incorrect sim issue, at the same time, before activation I cannot show them the wifi proble,

    any suggestion?
    Well you said it does not give you the invalid sim error on 1.1.4 right?

    You won't be able to show them this error either way.

    If you are not getting the invalid SIM error after you are on 1.1.4, you can show them is the wifi issue. Find an activated AT&T SIM, shift+restore to 1.1.4, and then show them the wifi issue. Don't do any hacks or whatever. it has to look OEM. They should replace it. Assuming your within your 1 year hardware warranty from Apple. Done!

  10. #10
    Rookie Array

    Join Date
    Jan 2008
    Posts
    25
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by enkrypt3d View Post
    Well you said it does not give you the invalid sim error on 1.1.4 right?

    You won't be able to show them this error either way.

    If you are not getting the invalid SIM error after you are on 1.1.4, you can show them is the wifi issue. Find an activated AT&T SIM, shift+restore to 1.1.4, and then show them the wifi issue. Don't do any hacks or whatever. it has to look OEM. They should replace it. Assuming your within your 1 year hardware warranty from Apple. Done!
    Thank you for your suggestion.

    After long time trying, I finally located the issue. Only restoring to 1.1.4 gives me the right IMEI starts from 0114XXXXX, and other fw gives the 0049XXXXX which causes the incorrect sim issue. If I can find a way to change IMEI back to 0114XXX under 1.0.2, it's no bother to stay with that version.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Need some help Incorrect sim
    By Plan B in forum Hardware
    Replies: 0
    Last Post: 07-14-2008, 05:27 AM
  2. Incorrect SIM
    By upsett3r in forum PwnageTool
    Replies: 1
    Last Post: 04-08-2008, 08:35 AM
  3. Incorrect Sim
    By mishad7 in forum iPhone "2G" (Rev. 1)
    Replies: 1
    Last Post: 10-16-2007, 10:54 PM
  4. Incorrect Sim!!!
    By djangelx in forum General
    Replies: 4
    Last Post: 09-29-2007, 07:55 AM
  5. Incorrect Sim
    By tom88 in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 09-21-2007, 08:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 11:51 AM.
twitter, follow us!