Page 8 of 15 FirstFirst 123456789101112131415 LastLast
Results 71 to 80 of 141
Discuss [All Firmware] Should we go from 4.6 to 3.9??? at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Originally Posted by donky HEY DUDE how will 3.9 bootloader void warrenty its a APPLE ...
  1. #71
    Board Hero Array

    Join Date
    Dec 2007
    Posts
    1,044
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    74

    Default

    Quote Originally Posted by donky View Post
    HEY DUDE how will 3.9 bootloader void warrenty its a APPLE bootloader its not custom buddy.
    From the Apple warranty:
    Quote Originally Posted by Apple
    This warranty does not apply: (...) (e) to a product or part that has been modified to alter functionality or capability without the written permission of Apple;
    You got written permission from Apple to downgrade your bootloader, "dude"?
    iPhone 3GS / 3.1.2 JB (PwnageTool) / 04.26.08 carrier-locked, Carrier Logo Fixer / Cydia / 1000 posts on Hackint0sh

    Installing Cydia programs on a phone that has no internet connection: read this.

    Editing binary .plist, .strings, .nib and .xib files:
    * on your computer: Windows tool / conversion website.
    * on your iPhone: convert those files in a terminal with plutil (installed with Erica Utilities) or edit them with iFile (Cydia links).


  2. #72
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    419
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Jim Danner View Post
    From the Apple warranty:You got written permission from Apple to downgrade your bootloader, "dude"?
    But they don't know i did it do they. And besides who cares about there stupid warranty bullshit policy. As if i am gonna return my iphone for repair coz i don't need to.

  3. #73
    Board Hero Array

    Join Date
    Dec 2007
    Posts
    1,044
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    74

    Default

    Quote Originally Posted by donky View Post
    But they don't know i did it do they. And besides who cares about there stupid warranty bullshit policy. As if i am gonna return my iphone for repair coz i don't need to.
    The problem is: we don't know whether they check the bootloader version when a warranty claim is made. Maybe they do and then maybe they refuse to honor the warranty. I think I remember reading that they refused service for an unlocked phone -- which also is no more than a software change.

    They can know you did it, because the serial number tells them which version you originally had. With their software it's probably possible to see the current versions of everything on the phone.

    The possibility of voiding the warranty is one of the things that could matter to people when they consider the bootloader downgrade. Even if you don't need to bring in your phone for repair.
    iPhone 3GS / 3.1.2 JB (PwnageTool) / 04.26.08 carrier-locked, Carrier Logo Fixer / Cydia / 1000 posts on Hackint0sh

    Installing Cydia programs on a phone that has no internet connection: read this.

    Editing binary .plist, .strings, .nib and .xib files:
    * on your computer: Windows tool / conversion website.
    * on your iPhone: convert those files in a terminal with plutil (installed with Erica Utilities) or edit them with iFile (Cydia links).

  4. #74
    Senior Professional Array

    Join Date
    Feb 2008
    Posts
    419
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Jim Danner View Post
    The problem is: we don't know whether they check the bootloader version when a warranty claim is made. Maybe they do and then maybe they refuse to honor the warranty. I think I remember reading that they refused service for an unlocked phone -- which also is no more than a software change.

    They can know you did it, because the serial number tells them which version you originally had. With their software it's probably possible to see the current versions of everything on the phone.

    The possibility of voiding the warranty is one of the things that could matter to people when they consider the bootloader downgrade. Even if you don't need to bring in your phone for repair.
    Yeah but 3.9 is still genuine apple bootloader.

  5. #75
    Board Hero Array

    Join Date
    Dec 2007
    Posts
    1,044
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    74

    Default

    Quote Originally Posted by donky View Post
    Yeah but 3.9 is still genuine apple bootloader.
    Yes, so it's not sure what will happen when they discover you have changed it. Do they mean just non-Apple software, or also software changed to Apple software that wasn't there before?

    The phrase "This warranty does not apply to a product that has been modified to alter functionality" seems to allow them to refuse service if you have modified the phone to have a different bootloader. There are no official bootloader changes through iTunes, so you didn't have permission (unlike with firmware/baseband updates: they come with a written license agreement that allows you to make the change).
    iPhone 3GS / 3.1.2 JB (PwnageTool) / 04.26.08 carrier-locked, Carrier Logo Fixer / Cydia / 1000 posts on Hackint0sh

    Installing Cydia programs on a phone that has no internet connection: read this.

    Editing binary .plist, .strings, .nib and .xib files:
    * on your computer: Windows tool / conversion website.
    * on your iPhone: convert those files in a terminal with plutil (installed with Erica Utilities) or edit them with iFile (Cydia links).


  6. #76
    Senior Professional Array ridderdk's Avatar

    Join Date
    Jan 2008
    Location
    Denmark
    Posts
    153
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    No questin about that,
    if Apple feels like refusing to repair an iPhone with up/downgraded bootloader, i'm sure they will win a lawsuit regarding this, that is, if anybody are foolish enough to start one. I bet the only thing you are entitled to do, is to upgrade the firmware.

  7. #77
    Rookie Array

    Join Date
    Jan 2008
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    No doubt, it appears that they're well within their rights to do refuse service on that basis.

    Regarding the OP question however, it seems that there's more than enough information available now to make an informed decision.

    If you want to run 1.1.3 with 4.03.13_G firmware then at this point in time, a bootloader downgrade would be the way to go. That said, this obviously comes with several well documented caveats and certainly not without risk.

    On the flipside, there appears to be a pretty good case for sticking with the OTB bootloader too, regardless of version.

    Ultimately, it's each users' decision. If you do your research thoroughly enough, you should be able to make your own mind up. The only thing I would say, is that if you had your iPhone for some time before getting it unlocked and it's currently working well on whatever it's current platform is, do you really want to risk breaking that for a point release in firmware?

    For the record, I had 1.1.2 OTB and hence 4.6bl, unlocked with gunlock. I subsequently upgraded to 1.1.3, unlocked, activated and performed the bootloader downgrade to 3.9 using ziphone 2.2 - all working perfectly. Had it gone wrong I would have possibly broken a reasonably expensive phone for no good reason. That was a risk I chose to take, not everyone may feel comfortable in taking that risk, or believe the benefits are worthwhile.

    The arguments fore and against are all fair and relevant - I just think that people need to weigh up the pros and cons, then make their own decision.

  8. #78
    Advanced Array

    Join Date
    Oct 2007
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Does anybody really think an Apple Genius is going to jailbreak a phone while you wait in the store so he can check the bootloader version??

  9. #79
    Senior Professional Array ridderdk's Avatar

    Join Date
    Jan 2008
    Location
    Denmark
    Posts
    153
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    Quote Originally Posted by dalton.voss View Post
    Does anybody really think an Apple Genius is going to jailbreak a phone while you wait in the store so he can check the bootloader version??
    hmm, no I don't
    But the point is, it's possible for Apple to find out

  10. #80
    Professional Array

    Join Date
    Jan 2008
    Posts
    55
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Quote Originally Posted by dalton.voss View Post
    Does anybody really think an Apple Genius is going to jailbreak a phone while you wait in the store so he can check the bootloader version??
    Well I dont know about Apple but in most major mobile companies they dont need to open it up to know whats up.In SE they just plug the cable and log into Emma and it gives them any single detail of the phone.Do you believe apples service software is not that sofisticated?I do because the more automated the process the more ignorant the repair men>the less likelyhood of leaking important internal info considering mechanisms which is Apples worst nightmare..

    Considering the Downgrade question it all lies to personal choice.I do both

    -For myself i keep the 4.6Bt since i do know what im doing with my phone
    -For 2 iphones I unloked for my GF and her friend i did downgrade it.Im damn sure they would press Upgrade in next firmware revision on itunes jugding by the zillions trojans on their pcs.Besides they dont want bleeding edge just a phone that works.
    -Living on a non US country means no matter what you have to pay for repair or an unsupported device.So people there dont have warranty no matter what.
    -One downside to Bl3.9 is that i think its developement has stopped.Neither Geo or any other of the scene is interested in making it upgradable and when the new FW and BL gets outs their hands will be full.

    So for those wanting to play 4.6 is the answer and those who need idiot proof design 3.9 is the answer


 

 

Similar Threads

  1. unlock: 2.2.1 firmware / bootloader 5.9 / modem firmware 04.26.08./sim gevey 3G.
    By djbigice in forum Turbo-, Supersim and Simcloning Solution
    Replies: 8
    Last Post: 03-17-2010, 08:26 PM
  2. Replies: 0
    Last Post: 07-20-2008, 04:07 PM
  3. Replies: 0
    Last Post: 07-11-2008, 10:41 PM
  4. Replies: 3
    Last Post: 01-20-2008, 11:23 AM
  5. Replies: 0
    Last Post: 08-29-2007, 05:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:01 PM.
twitter, follow us!