iplus also works on 1.1.3.. done it on a lot of phones coz i didnt bother to check their firmware versions... and they all worked just fine... of course i had to update them to 1.1.4 coz i wanted the latest firm... but point being... iplus should work