Results 1 to 8 of 8
Discuss [1.1.3] Mail kicking back to home screen at the iPhone "2G" (Rev. 1) - Hackint0sh.org; When I tap the 'Mail' button, it momentarily takes me to a blank mail page ...
  1. #1
    Advanced Array maXimus1's Avatar

    Join Date
    Aug 2007
    Location
    1824'N ~ 6605'W
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default [1.1.3] Mail kicking back to home screen

    When I tap the 'Mail' button, it momentarily takes me to a blank mail page but then immediately kicks me back to the home screen. If I try to tap on the email address in one of my contacts, the same thing happens.

    I downgraded to 1.1.1, Oktoprep, 1.1.2 jailbreak, Official Dev Team 1.1.3 jailbreak v. 3.



  2. #2
    Newbie Array

    Join Date
    Sep 2007
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by maXimus1 View Post
    When I tap the 'Mail' button, it momentarily takes me to a blank mail page but then immediately kicks me back to the home screen. If I try to tap on the email address in one of my contacts, the same thing happens.

    I downgraded to 1.1.1, Oktoprep, 1.1.2 jailbreak, Official Dev Team 1.1.3 jailbreak v. 3.
    i'm having the exact same problem.

  3. #3
    Professional Array

    Join Date
    Oct 2007
    Posts
    53
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    9

    Default

    Had the same problem, this worked for me

    chmod +s /Applications/MobileMail.app/MobileMail

  4. #4
    Newbie Array

    Join Date
    Feb 2008
    Posts
    1
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    This happened to me. I'd installed Nate True's jailbreak previously, then tried to restore my data through iTunes to the Dev Team's 1.1.3.

    I fixed the problem by restoring from a slightly older backup. That works if you have one, but I lost an SMS or two. :/

    It makes sense that running MobileMail as root would fix this though. Nate True's jailbreak runs everything as root, just like 1.1.2 did. The Dev Team's jailbreak runs apps as mobile, like in stock 1.1.3.

    A better fix would be to correct whatever permission problem prevents MobileMail from running as mobile. There's probably a preference file somewhere that belongs to root; correcting the permissions on that should make mail work again.

  5. #5
    Newbie Array

    Join Date
    Jan 2008
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I had this same problem, it had to do with restoring a backup of 1.1.3 on a 1.1.2 jailbroken phone (before upgrading to 1.1.3) or something along those lines.

    Basically I had restored an incompatible mail backup and it wouldn't load. This was fixed by doing it without restoring. I lost some data, but most of it was synced on my computer anyways (mail/address book/iCal/etc) so I wouldn't worry.

    If all else fails, try that

    Good luck!


  6. #6
    Advanced Array maXimus1's Avatar

    Join Date
    Aug 2007
    Location
    1824'N ~ 6605'W
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thanks guys! The problem was loading a Nate-jailbreak backup to a Dev Team-jailbreak. Definitely NOT compatible!

  7. #7
    Rookie Array

    Join Date
    Oct 2007
    Posts
    23
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    This happens to a college of mine. she gets a "mail orphaned" file in the mail storage. ie a file was downloading but didn't finish.

    if you search the forums they have the exact method to this. you need to delete the orphaned file and your good to go.

  8. #8
    Newbie Array

    Join Date
    Dec 2007
    Posts
    6
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    add modmyifone to installer and then install youtube fix from unlock category it will also fix the mail problem

 

 

Similar Threads

  1. Replies: 1
    Last Post: 02-11-2009, 08:24 PM
  2. [MobileMusicPlayer] Won't open > Goes white then back to Home screen
    By nyzrox in forum Free Toolchain Software (Cydia App's)
    Replies: 6
    Last Post: 07-02-2008, 04:08 PM
  3. Installer crashing back to home screen...?!
    By toydesign in forum Free Toolchain Software (Cydia App's)
    Replies: 0
    Last Post: 03-06-2008, 04:13 AM
  4. [PROBLEM] After Upgrade, it kicks back to the Home Screen
    By egyptfixer_ramy in forum Free Toolchain Software (Cydia App's)
    Replies: 3
    Last Post: 02-09-2008, 11:33 AM
  5. Replies: 6
    Last Post: 10-23-2007, 01:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 01:27 PM.
twitter, follow us!