I just went throught the entire process and got to installing 1.1.3 soft upgrade and it fails error about firmware needs to be 1.1.2

Question 1: what could be the cause of this error.

Question 2: if i am successful, can I put ny Cingular SIM in get a functional iphone?

Question 3: I read on Nates site that the ONLY way to activate the iphone after JB 1.1.3 is with a working AT&T SIM, is this true?