Quote Originally Posted by huecobros View Post
Dont listen to that clown, just DFU restore to 1.1.4. and then use ilberty to unlock, jailbreak and activate (DONT USE ZIPHONE!).
yeah as i said it's better to have the latest version