Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 40
Discuss [1.1.2 OTB] Is the new GeoHot unlock 1.1.3 Update-proof? at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Originally Posted by Drkeys Guys, Ok Guys, i believe you guys are getting stuff mixed ...
  1. #21
    Advanced Array

    Join Date
    Jan 2008
    Location
    Toronto,Canada
    Posts
    37
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Drkeys View Post
    Guys,


    Ok Guys, i believe you guys are getting stuff mixed up

    First of all Get your phone unlocked first using GeoHot method

    Downgrade via "Restore", 1.1.1, JB, OkPrep, BSD Sub, VT-Term, Airplane Mode On
    Unlock via Geohot Method, then make sure you restore airplant mode off
    Upgrade to 1.1.2. Now you have an unlocked 1.1.2 with 04.02.12 BB and BL 4.6 Patched

    above is a normal process for unlocking and is confirmed.
    In order to test to see if it is upgrade resistant " YOU DO NOT WANT TO RESTORE to 1.1.3" , you want to "UPGrade" to 1.1.3. Restore process cleans up everything, probably undo a lot of GeoHot'z Method, probably rewrite BB and BootLoad since it checks all integrity points. So i don't know why people keeping on RESTORING to 1.1.3 when they should just "upgrade" to 1.1.3. We're testing to see if the unlock is "UPGRADE RESISITANT" not "RESTORE RESISTANT"


    Now, we have things cleared up.
    Then Upgrade to 1.1.3 to get the Baseband to 04.03.12 from 04.02.12, Downgrade to 1.1.1, JB, OKtoPrep, then "upgrade" to 1.1.2, and JB via java jailbreakme.com.

    Remember. you now have an JB 1.1.2 with Bootloader 4.6 patched from the unlock. but the BB is 04.03.12. In order for the phone to work again. You have to be back to 1.1.3 plus you want to able to use installer APP. So I would recommend to do a Softupdate Via Offfice dev-team 1.1.3-3 softupdate to get back to 1.1.3 now you have a JB and unlocked 1.1.3 with BB 04.03.12 and BL 4.6 patched still.


    Post your feed back on this, Mine works i have att sim but i don't have an non-ATT sim to test
    congratulations, you now have a 1.1.3 iPod Touch with 4.03.13_G BB but nothing to do with iPhone! Once you implement Geohot's SW unlock, your iphone will be 4.02.13_G BB!


  2. #22
    Rookie Array

    Join Date
    Feb 2008
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    yeah.. that was the first step,


    you do not do the Geohot SW unlock method in the 2nd Step, so when you "Upgrade" to 1.1.3 (you get bb 4.03.12) not 04.02.12.

    Then you have to downgrade to 1.1.1, JB, Oktoprep,
    Upgrade to 1.1.2, JB, then.... you Softupgrade using official Dev-team 1.1.3-3 (it doesn't tcouh the baseband).

    and did you see me mentioning GeoHot Unlocking Step anywhere here? NO,..so go back and read it..again.!!!! you skipped out a lot of details to come up with your conclusion

  3. #23
    Professional Array

    Join Date
    Nov 2007
    Posts
    95
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    12

    Default

    Quote Originally Posted by Drkeys View Post
    yeah.. that was the first step,


    you do not do the Geohot SW unlock method in the 2nd Step, so when you "Upgrade" to 1.1.3 (you get bb 4.03.12) not 04.02.12.

    Then you have to downgrade to 1.1.1, JB, Oktoprep,
    Upgrade to 1.1.2, JB, then.... you Softupgrade using official Dev-team 1.1.3-3 (it doesn't tcouh the baseband).

    and did you see me mentioning GeoHot Unlocking Step anywhere here? NO,..so go back and read it..again.!!!! you skipped out a lot of details to come up with your conclusion
    Probably being a bit dim here but:
    I have just got a 1.1.3 OTB phone. I downgraded to 1.1.1, jailbroke and unlocked using Geohot method...upgraded to 1.1.2, jailbroke, installed BSD subsystem and used the official dev team installer upgrade to 1.1.3.
    I now have 1.1.3, 04.02.13, 4.6....and all is working fine.
    Are you saying if I had gone back up to 1.1.2....then upgraded through iTunes to 1.1.3....then restored again to 1.1.1, jailbroken, oktoprep, upgrade to 1.1.2 then use the official dev team 1.1.3-3, I will have an unlocked phone on 1.1.3 with 04.02.13?

    At least I think that's what you mean.

  4. #24
    Rookie Array

    Join Date
    Feb 2008
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by iainmann View Post
    Probably being a bit dim here but:
    I have just got a 1.1.3 OTB phone. I downgraded to 1.1.1, jailbroke and unlocked using Geohot method...upgraded to 1.1.2, jailbroke, installed BSD subsystem and used the official dev team installer upgrade to 1.1.3.
    I now have 1.1.3, 04.02.13, 4.6....and all is working fine.
    Are you saying if I had gone back up to 1.1.2....then upgraded through iTunes to 1.1.3....then restored again to 1.1.1, jailbroken, oktoprep, upgrade to 1.1.2 then use the official dev team 1.1.3-3, I will have an unlocked phone on 1.1.3 with 04.02.13?

    At least I think that's what you mean.

    Ok if you currently have an unlocked and jailbroken (via devteam 1.1.3 softupdate) 1.1.3 will give what you have now: 1.1.3 with BB 04.02.12 and BL 4.6

    as you know, there are just tons of problems with the 1.1.3 softupdate without having the baseband as 04.03.12

    My solution is to end up with 1.1.3 softupdated iphone that is unlocked but with 04.03.12 BB and BL 4.6 (NOT 04.02.12 BB, the 1.1.2 Baseband)

    So that all the functions such as locate on google maps and other stuff will work.
    That's when the 2nd step comes in

    after you obtained an unlocked 1.1.2 via Gehot'z method (BB 04.02.12) you have two options to get to 1.1.3

    1) The old fashion way with issues since 04.02.12 bb is not touched: upgrade via dev team softupdate 1.1.3-3. and apply all the fixes

    2) upgrade (NOT RESTORE) via itunes to 1.1.3 to get the baseband up to 04.03.12
    then downgrade back to 1.1.1, JB, oktoprep. upgrade to 1.1.2, JB, then finally do the softudpate from Devteam 1.1.3-3 to get back to 1.1.3 (NOTE: your baseband will remain 04.03.12 through all the downgrading and upgrading step and your phone will not work until you get back to firmware 1.1.3 via the official 1.1.3 softupdate since baseband and firmware has to match)

    I believe right now, you have an 1.1.3 iphone with option 1) state (BB 04.02.12, and BL 4.6) jailborken and unlocked with functions not working properly

    If you try option 2). you'll end up with 1.1.3 iphone state (BB 04.03.12 and BL 4.6) jailbroken and unlocked with everything functions correctly since baseband and firmware match.

    Hope that clears up

  5. #25
    Senior Professional Array

    Join Date
    Dec 2007
    Posts
    352
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    30

    Default

    Quote Originally Posted by Drkeys View Post
    2). you'll end up with 1.1.3 iphone state (BB 04.03.12 and BL 4.6) jailbroken and unlocked with everything functions correctly since baseband and firmware match.
    no you wont... it wont be unlocked gunlock patches NCK check in 04.02.13 BB, with upgrading BB this check becomes active again, so its _impossible_ that is stays unlocked


  6. #26
    Senior Professional Array

    Join Date
    Nov 2007
    Posts
    171
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    whats the dif if you upgrade/restore to 1.1.3??? upgrade would just let you keep you stuff on the iphone i just do a restore to .1.1.3, so that you get a fresh new iphone to start with...

  7. #27
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    141
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    As far as I understand the "update proof" unlock by geohot ONLY works for 3.9 BL phones. This IFSF style unlock was announced on February 4 already, it can be found here (http://lpahome.com/geohot/ipsftool.rar), and may be update proof.

    The Geounlock unlock (included in installer) was announced 4 days later. This one is only meant for BL 4.6 (1.1.2 OTB and 1.1.3 OTB) phones and is different from the the IFSF style unlock and is not update proof.

    Correct me if I'm wrong...

  8. #28
    Advanced Array

    Join Date
    Dec 2007
    Posts
    44
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by Don_Ron View Post
    As far as I understand the "update proof" unlock by geohot ONLY works for 3.9 BL phones. This IFSF style unlock was announced on February 4 already, it can be found here (http://lpahome.com/geohot/ipsftool.rar), and may be update proof.

    The Geounlock unlock (included in installer) was announced 4 days later. This one is only meant for BL 4.6 (1.1.2 OTB and 1.1.3 OTB) phones and is different from the the IFSF style unlock and is not update proof.

    Correct me if I'm wrong...
    That's my observation too...
    People mix 2 masterpieces of Geo into one without his agreement... hahaha...
    But it might be the sign showing what's inside our sub-concious mind that we also need soft unlock 4.03.13. May people lost themselves and wanna to where they/we are... So please "locate me".

    .... I don't wanna ask too much while I can't do anything but wait...

  9. #29
    Professional Array

    Join Date
    Jan 2008
    Posts
    60
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    The confusion over this issue comes from this paragraph on geohot's blog, in the post announcing the 4.6BL unlock (emphasis added):
    The third minor concern was the full range check of 1.1.3. So use 1.1.2 This allows full unsigned code execution, it is a relatively simple matter of patching the bootloader to skip the range check. And while you are at it, patch the bootloader to validate all tokens. IPSF style unlock w/o touching the seczone.
    This led some of us to believe that this was a permanent unlock. This has been shown to not be the case. The unlock requires patched baseband firmware, so going to 1.1.3 via iTunes - be it update or restore, the difference is unimportant - will lock the phone again.

  10. #30
    Rookie Array

    Join Date
    Feb 2008
    Posts
    27
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    duplicate thread.. see next one
    Last edited by Drkeys; 02-11-2008 at 03:46 AM.


 

 
Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. [1.1.2 otb to 1.1.3]DevOfficial update after geohot'z unlock?
    By carouselboy in forum iPhone "2G" (Rev. 1)
    Replies: 14
    Last Post: 02-09-2008, 07:06 PM
  2. (1.1.1) are iphones with BL 3.9 future update proof !
    By rajeevsharma8888 in forum General
    Replies: 3
    Last Post: 01-10-2008, 03:44 PM
  3. Geohot Unlock and 1.1.1 Update
    By mt404 in forum iPhone "2G" (Rev. 1)
    Replies: 4
    Last Post: 09-28-2007, 12:27 PM
  4. A Tinhead-Proof Free Unlock Guide (OS X)
    By Locked in forum General
    Replies: 15
    Last Post: 09-13-2007, 09:52 AM
  5. Idiot-proof Mac unlock guide
    By Peacer in forum General
    Replies: 2
    Last Post: 09-12-2007, 08:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:02 AM.
twitter, follow us!