Hi People...

I am not new to all this jailbreaking / unlocking business... but I need some advice.

My iPhone is 1.1.2 OTB, which I have jailbroken by going into DFU, downgrading OS to 1.1.1. Jailbroke, and oktoprep'd then back to 1.1.2.
I am unlocked by using an xSIM.
So I have 1.1.2, BL4.6, 04.02.13BB

I've been eyeing up all the different ZiPhone releases, and I've got the 2.4 sitting on my desktop... I've been waiting around for anything from Geohot on the custom BL before I go ahead and use ZiPhone.

If I use ZiPhone I would want to downgrade the BL to 3.9 as it seems that more is known about the holes in it (and I'd get full google localization)

If I want to do that I know I need to do a proper upgrade via iTunes to 1.1.3 - but if I want to then use ZiPhone to downgrade the BL do I need to do that first before doing any jailbreak / activation?

Or should I just sit tight, and see what happens with 1.1.4 coming soon?

It's driving me nuts!!