Page 1 of 2 12 LastLast
Results 1 to 10 of 18
Discuss [1.1.2 or 1.1.3 OTB][Problem] ZiPhone Jailbreak issue with iPhoneBrowser/ iBrickr at the iPhone "2G" (Rev. 1) - Hackint0sh.org; Hey Guys, I have searched the forums and found one other person who has noticed ...
  1. #1
    Senior Professional Array FrostiPhone's Avatar

    Join Date
    Jan 2008
    Location
    Perth, Australia
    Posts
    192
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Exclamation [1.1.2 or 1.1.3 OTB][Problem] ZiPhone Jailbreak issue with iPhoneBrowser/ iBrickr

    Hey Guys, I have searched the forums and found one other person who has noticed this issue and no body answered him so here is a thread for the problem.

    I have an OTB 1.1.2 iPhone and I just used ZiPhone to Activate, Jailbreak and Unlock it. Everything worked like a charm but there is a problem with the jailbreak part. Installer is installed and #rd party apps install thru it no problem but when i open iPhoneBrowser it says the iPhone is connected but not Jailbroken...Then I opened iBrickr and the first thing it wants to do is "Free the iPhone" which it shouldnt say if the jailbreak was successful. I did the ZiPhone Jailbreak again with success but it hasnt changed anything. So has this happened to anyone else? Is there a way to fix this? Having Installer is great but we also need to be able to add things with iPhoneBrowser and iBrickr. Can anyone shed any light on this please? Thanks.



  2. #2
    Senior Professional Array jawnsixteen's Avatar

    Join Date
    Oct 2007
    Location
    Boston
    Posts
    151
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    14

    Default

    i haven't heard of this issue, i would try a fresh restore and see if it happens again

  3. #3
    Amazingly Knowledgeable Array bezman's Avatar

    Join Date
    Aug 2007
    Location
    Trinidad
    Posts
    796
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    54

    Default

    i saw the same thing... i am sure they will fix..

  4. #4
    Senior Professional Array FrostiPhone's Avatar

    Join Date
    Jan 2008
    Location
    Perth, Australia
    Posts
    192
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    Quote Originally Posted by bezman View Post
    i saw the same thing... i am sure they will fix..
    Well at least Im not crazy haahhaa
    The Guy Above Me is Touching My Special Place!

  5. #5
    Rookie Array titus's Avatar

    Join Date
    Sep 2007
    Posts
    22
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by FrostiPhone View Post
    Hey Guys, I have searched the forums and found one other person who has noticed this issue and no body answered him so here is a thread for the problem.

    I have an OTB 1.1.2 iPhone and I just used ZiPhone to Activate, Jailbreak and Unlock it. Everything worked like a charm but there is a problem with the jailbreak part. Installer is installed and #rd party apps install thru it no problem but when i open iPhoneBrowser it says the iPhone is connected but not Jailbroken...Then I opened iBrickr and the first thing it wants to do is "Free the iPhone" which it shouldnt say if the jailbreak was successful. I did the ZiPhone Jailbreak again with success but it hasnt changed anything. So has this happened to anyone else? Is there a way to fix this? Having Installer is great but we also need to be able to add things with iPhoneBrowser and iBrickr. Can anyone shed any light on this please? Thanks.
    Connect to your iPhone via SSH connection

    go edit \System\Library\Lockdown\Services.plist

    Check if AFC2 is allowed right after the first service AFC

    <key>com.apple.afc</key>
    <dict>
    <key>AllowUnactivatedService</key>
    <true/>
    <key>Label</key>
    <string>com.apple.afc</string>
    <key>ProgramArguments</key>
    <array>
    <string>/usr/libexec/afcd</string>
    <string>--lockdown</string>
    </array>
    </dict>
    <key>com.apple.afc2</key>
    <dict>
    <key>AllowUnactivatedService</key>
    <true/>
    <key>Label</key>
    <string>com.apple.afc2</string>
    <key>ProgramArguments</key>
    <array>
    <string>/usr/libexec/afcd</string>
    <string>--lockdown</string>
    <string>-d</string>
    <string>/</string>
    </array>
    </dict>


    This would allow the use of iphonebrowse and other apps.


  6. #6
    Advanced Array ivanlinares's Avatar

    Join Date
    Oct 2007
    Location
    Culiacan, Sinaloa.
    Posts
    30
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Same problem here, hope zibree fix it!

  7. #7
    Senior Professional Array FrostiPhone's Avatar

    Join Date
    Jan 2008
    Location
    Perth, Australia
    Posts
    192
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    I tried to SSH into the phone but it seems I cant even do that....Please anyone who has this problem help us to sort it out! Someone msg Zibri lol. I really need to use iPhonebrowser....

    One other thing - Before Zibri and GeoHot had released these unlocks and everyone with OTB 1.1.2 could only activate and JB them. When you use the 1.1.2 Jailbreak it installed SSH for you, and now after the ZiPhone Unlock I install Open SSH but i dont get that icon of the switch that you can turn it on or off. How do i get that icon or is it a different SSH program??
    Last edited by FrostiPhone; 02-12-2008 at 03:15 PM.
    The Guy Above Me is Touching My Special Place!

  8. #8
    Senior Professional Array Twisty iphoney's Avatar

    Join Date
    Oct 2007
    Posts
    492
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    34

    Default

    Hey,
    I have already posted it on his blog today. hope he fixes it soon.

    Twisty iphoney ha detto... @zibri

    sorry to bother again but i just have a wi-fi router with no wi-fi internet connection. Also I don't have edge on my phone. So please help. Also it would be nice if you enable afc2 service by default in /System/Library/Lockdown/Services.plist.
    thanks

  9. #9
    Senior Professional Array FrostiPhone's Avatar

    Join Date
    Jan 2008
    Location
    Perth, Australia
    Posts
    192
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    16

    Default

    Thanks Twisty iphoney
    The Guy Above Me is Touching My Special Place!

  10. #10
    Newbie Array

    Join Date
    Feb 2008
    Posts
    8
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    titus's method does work!

    Here's a little bit more detailed explanation:

    After you've got your phone all jailbroken/activated with ziphone (1.1.3)
    - Install OpenSSH through installer
    - Download Putty http://the.earth.li/~sgtatham/putty/.../x86/putty.exe
    - open up putty and enter in the ip address of your phone (found in settings->wifi on your phone) and click open
    - it'll take a few seconds the first time (like 30 or so)
    - A prompt will come up eventually. login as root, password alpine
    - type cd ../../System/Library/Lockdown
    - type pico Services.plist
    The file should look like this starting at the top:
    <dict>
    <key>com.apple.afc</key>
    <dict>
    <key>AllowUnactivatedService</key>
    <true/>
    <key>Label</key>
    <string>com.apple.afc</string>
    <key>ProgramArguments</key>
    <array>
    <string>/usr/libexec/afcd</string>
    <string>--lockdown</string>
    <string>-d</string>
    <string>/var/mobile/Media</string>
    <string>-u</string>
    <string>mobile</string>
    </array>
    </dict>
    INSERT CODE HERE
    <key>com.apple.crashreportcopy</key>
    <dict>

    Here's what you need to insert where the red lettering is above:
    <key>com.apple.afc2</key>
    <dict>
    <key>AllowUnactivatedService</key>
    <true/>
    <key>Label</key>
    <string>com.apple.afc2</string>
    <key>ProgramArguments</key>
    <array>
    <string>/usr/libexec/afcd</string>
    <string>--lockdown</string>
    <string>-d</string>
    <string>/</string>
    </array>
    </dict>


    - When done, hit ctrl+x to exit and save at the prompt.
    - Close out of putty
    - reboot your iphone
    - Now you should be able to use iphonebrowser to see everything!


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. [Problem] Jailbreak issue
    By boywonda in forum iPhone 3G
    Replies: 2
    Last Post: 10-26-2008, 06:42 PM
  2. Replies: 4
    Last Post: 03-07-2008, 06:38 PM
  3. [Tutorial] [1.1.3 iBrickr/iPhoneBrowser Problems]
    By NuKeZ in forum iPhone "2G" (Rev. 1)
    Replies: 9
    Last Post: 02-16-2008, 05:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:28 PM.
twitter, follow us!