Results 1 to 7 of 7
Discuss 1.1.1 with 1.0.2 (03.14.08_G) baseband at the iPhone "2G" (Rev. 1) - Hackint0sh.org; I've heard of people running 1.0.2 with 1.1.1 baseband and at least once there was ...
  1. #1
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default 1.1.1 with 1.0.2 (03.14.08_G) baseband

    I've heard of people running 1.0.2 with 1.1.1 baseband and at least once there was a posting about a proof-of-concept way to use 1.1.1 OS part (Mac OS X) with the old 03.14.08_G baseband firmware.

    Has anyone done it? It may be a short term workaround for those that have *free* unlocked at 1.0.2 and want to try 1.1.1.

    Another potential use of this hybrid mode maybe to solve the missing voicemail notification problems some folks are reporting under 1.1.1 (was working under 1.0.2)

    *If* this can work (I'm not claiming it does) , I would say that it will require something like the followling:

    1) Start with a 1.0.2 iPhone, that was previously unlocked with the old anySIM or its siblings (unlocker.app and iUnlock - HW and SW versions).

    1) Perform the 1.1.1 upgrade/jailbreak proceedure.

    2) Using SSH under 1.1.1 downgrade the baseband using the same proceedure one would under 1.0.2. This will put the old baseband code, but the OS part would still be 1.1.1

    3) Re-unlock using the "OLD" anySIM. The resulting bb firmware should be able to see past the corrupted seczone.

    Then the question: will this work? Is there anything in 1.1.1 that really requires the new 04.xx baseband firmware?



  2. #2
    Rookie Array

    Join Date
    Aug 2007
    Posts
    18
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    I have tried that for several times; it works until you restart the iPhone. So this solution is rather temporary.

  3. #3
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default

    What happens when you restart the phone?

  4. #4
    Newbie Array

    Join Date
    Oct 2007
    Posts
    2
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by aviegas View Post
    What happens when you restart the phone?
    incorrect SIM

  5. #5
    Rookie Array

    Join Date
    Oct 2007
    Posts
    21
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Yes, You can run 1.1.1 with 1.0.2 BB with all functions for 1.1.1 by change the lockdownd of 1.1.1 to lockdownd 1.0.2. but the problem is you can't sync or charge with PC and Power cost. Until you use the wifi and copy back file lockdownd of 1.1.1 and reset the phone. But when do that you can sync with PC but NO Phone functions.


  6. #6
    The Man Array aviegas's Avatar

    Join Date
    Sep 2007
    Posts
    1,108
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    73

    Default

    Quote Originally Posted by melbmoon View Post
    Yes, You can run 1.1.1 with 1.0.2 BB with all functions for 1.1.1 by change the lockdownd of 1.1.1 to lockdownd 1.0.2. but the problem is you can't sync or charge with PC and Power cost. Until you use the wifi and copy back file lockdownd of 1.1.1 and reset the phone. But when do that you can sync with PC but NO Phone functions.
    Hum... is the reason for replaceing the 1.1.1 lockdown related to the "Incorrect SIM" that was also reported when attempting the approach? If yes, it looks to me that a patched version of lockdown 1.1.1 may do the trick.

    Somethng like the patched lockdown for 1.0.2 that allowed one to swap SIM cards without the need to reactivate?

    Patching lockdown is orders of magnitude simpler than fixing the seczone.

  7. #7
    Newbie Array

    Join Date
    Oct 2007
    Posts
    9
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Here's what you have to do:

    1.) Boot with lockdownd v.1.1.1
    2.) Switch to lockdownd v.1.0.2 and kill the lockdownd process

    This way, your phone will sync, and you can use it as a phone. The problem here is that initially, iTunes will say that it can't read the iPhone. I've fiddled around and managed to get my phone so it will work as a phone AND sync with iTunes, but I haven't really figured out which of my many actions caused it to be the way it is. Furthermore, the steps above need to be repeated on every reboot.

    I suggest waiting for the virginizer.

 

 

Similar Threads

  1. Replies: 43
    Last Post: 01-03-2008, 03:18 AM
  2. Upgrading the baseband from 03.14.08_G to 04.01.13_G
    By Juanmih in forum iPhone "2G" (Rev. 1)
    Replies: 4
    Last Post: 10-19-2007, 12:10 AM
  3. Do i need to re-lock if i have 03.14.08_G baseband?
    By cc2k4 in forum iPhone "2G" (Rev. 1)
    Replies: 0
    Last Post: 10-15-2007, 11:31 PM
  4. Replies: 1
    Last Post: 10-13-2007, 12:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 09:59 AM.
twitter, follow us!