Results 1 to 7 of 7
Discuss [1.0.2 (1.1.2 OTB)][Problem downgrading bootloader] at the iPhone "2G" (Rev. 1) - Hackint0sh.org; my iPhone... Week - 47 1.1.2 O.O.B from USA Apple store updated to 1.1.3 then ...
  1. #1
    Rookie Array

    Join Date
    Jan 2008
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Exclamation [1.0.2 (1.1.2 OTB)][Problem downgrading bootloader]

    my iPhone...

    Week - 47
    1.1.2 O.O.B from USA Apple store

    updated to 1.1.3 then downgraded the firmware to 1.0.2 - the modem firmware is still 04.03.13_G

    Took phone apart and have turned A17 testpoint on.

    My Problem = cant downgrade bootloader to 3.9

    Code:
    # launchctl unload /System/Library/LaunchDaemons/com.apple.CommCenter.plist
    # ienew
    Resetting the Baseband...Done
    Opened: /dev/tty.baseband
    iEraser for 112OTB: tool by geohot
    Waiting for data...
    Got Header: 77 0b cc
    02 00 85 00 02 00 FF FF 85 02 03 00
    SECPACK
    02 00 04 02 06 00 01 00 00 00 00 00 0B 02 03 00
    Erase
    02 00 05 08 02 00 00 00 07 08 03 00
    02 00 06 08 06 00 01 00 00 00 A0 00 AD 08 03 00
    Hopefully the main flash was erased, wait for the next step...
    #
    (I connect the 2 Points)
    Code:
    # iunew
    Resetting the Baseband...Done
    Opened: /dev/tty.debug
    iUnlocker: tool by geohot
    Modified to erase
    Spamming AT, waiting for a response
    Attempting to read[1]...c0
    Connected established to bootrom
    File size: 1688
    Checksum: 0xBF
    Attempting to read[1]...c1
    Did you erase the flash first?
    #
    every time it tells me "Did you erase the flash first?"
    one time it told me "Please connect the testpoint"

    Anyone else get this?



  2. #2
    Rookie Array

    Join Date
    Jan 2008
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    can someone help me before my brother finds out what i did to his phone?

  3. #3
    Advanced Array

    Join Date
    Jun 2007
    Posts
    40
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    It only works if you have the 1.1.2 baseband. But you updated to the 1.1.3 baseband, so you have to wait for 1.1.4 to be able to do it.

  4. #4
    Professional Array moho's Avatar

    Join Date
    Dec 2007
    Posts
    65
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    you upgraded to 1.1.3.
    your toast until a new FW with a new BL is released.
    void unlock(int& Iphone)
    char FRUSTRATION(true);
    do
    {
    Unlock(Iphone);
    }while (FRUSTRATION=='true');

  5. #5
    Rookie Array

    Join Date
    Jan 2008
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    so, once the 1.1.4 firmware is released. i extract the secpack file from it, and can perform this procedure without any problems?


  6. #6
    Newbie Array

    Join Date
    Jan 2008
    Posts
    5
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    my phone was 112 dowgraded to 111 then i ran ienew. output was as it should be then ran iunew and it gave me the 'Did you erase the flash first? can anybody help. Dont know what to do next. Do i erase and try again?

  7. #7
    Advanced Array

    Join Date
    Dec 2007
    Posts
    45
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Hi,

    I've managed to successfully unlock an 1.1.2 OTB iPhone (not the one i recently bricked), almost. After connecting the testpoint and running 'iunew' successfully I have been unable to write any firmware version successfully so again I have a 'repair needed' phone. However I was now able to downgrade to 1.0.2, manually jailbreak and activate it and have copied all the tools needed to repeat the operation.

    This time 'ienew' fails with 'Can't write', and 'iunew' sometimes stays at 'Spamming AT, waiting for response' and sometimes it spits 'Did you erase the flash first?'.

    Whenever I try to run bbupdater (be it with -v or specifying a .fls and .eep file with -f and -e) it says 'Error: Failed to initialize comm layer: (is it open by another app?)'.

    Just to note: I have indeed stopped the CommCenter, and all the related files needed to do the unlock have the correct permissions on them.

    Regards and thanks for your time.

 

 

Similar Threads

  1. Replies: 4
    Last Post: 03-11-2008, 01:02 AM
  2. Problem downgrading to 1.1.1 from 1.1.3
    By molopo in forum General
    Replies: 11
    Last Post: 03-08-2008, 03:26 AM
  3. Replies: 13
    Last Post: 02-23-2008, 11:27 AM
  4. [Testpoint] Downgrading Bootloader from 4.6 to 3.9
    By SamB in forum iPhone "2G" (Rev. 1)
    Replies: 5
    Last Post: 01-29-2008, 12:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 04:06 PM.
twitter, follow us!