HI everybody,

I have a GSM Iphone 4 on 5.0.1 which has been unlocked for a while (by operator)

I did not bother to update to 5.1.1 as everything was working fine. (and because I was lazy too )

Now, some apps on appstore need >=iOS 5.1
I got 5.1 and 5.1.1 shsh saved with tinyumbrella. Cydia got them too.

I wanted to know if its possible with tinyumbrella to upgrade to 5.1.1 and using the tss server from tinyumbrella, then jailbreak with the usual tools ? I already made that sometime but it was for the same firmware, not for a superior one.

Thanks for your help !