So, I'm stuck in trying to follow directions.. seems like some of these pages are old.

I updated the phone to 5.1.1 with old baseband, and ultrasn0w didn't unlock it.. of course,
I didn't read the baseband.

iOs 5.1.1
BB 05.16.02
serial is xx027

Can I still update to iPad bb? I could only find directions for that with ios 4.1

Can I downgrade to 4.1 .

or is there another option? I saw something about CommCenter* patch

any help would be greatly appreciated!