Results 1 to 5 of 5
Discuss Weird WiFi problem at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; My iPhone 3GS has been jailbroken and unlocked - for more than a week - ...
  1. #1
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default Weird WiFi problem

    My iPhone 3GS has been jailbroken and unlocked - for more than a week - and all of a sudden, i am having problem with WiFi. I can join a WiFi network and i can see the IP addresses and all that, but for some reason, iPhone does not think it is connected to the network and there is no WiFi icon on the top of the phone. Also, if i go to the WiFi Networks menu under Settings, even with "Ask to join networks" setting on, it does not prompt me to join the list of available WiFi networks.

    I have tried to resetting the Network Settings multiple times, rebooting the phone, installing and uninstall SBSsettings. Yesterday, during a brief moment, WiFi came back but it went away pretty quickly. The only thing that i can think of that was added to my iPhone was some official app updates.

    Has anyone experienced this problem before?

    iPhone info: old boot ROM, iOS 4.0, Baseband 05.13.04, patched CommCenter to allow non-official IPCC (this was patched for more than a week and WiFI had been working fine).



  2. #2
    Rookie Array

    Join Date
    Jul 2010
    Posts
    19
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    you should update to 4.0.1

  3. #3
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    I'm assuming you did the CommCenter patch for tethering? If so, have you tried reverting to the original / non-patched and rebooting to see if that resolves the issue? While I can agree it doesn't seem like it would be related due to the timing of the onset of the issue, if it's the only thing you've done that impacts that area of the phone, a quick test shouldn't hurt.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!


  4. #4
    Senior Professional Array

    Join Date
    Jul 2007
    Posts
    244
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    19

    Default

    Quote Originally Posted by n1ckn4m3 View Post
    I'm assuming you did the CommCenter patch for tethering? If so, have you tried reverting to the original / non-patched and rebooting to see if that resolves the issue? While I can agree it doesn't seem like it would be related due to the timing of the onset of the issue, if it's the only thing you've done that impacts that area of the phone, a quick test shouldn't hurt.
    I have not reverted to the original CommCenter yet. For now, being able to tether is a lot more important than being able to connect to some WiFi networks with no security. I have narrowed the problem down to unprotected WiFi networks. So far, i have no problem connecting to WPA2-protected WiFi networks.

  5. #5
    Super Moderator Array n1ckn4m3's Avatar

    Join Date
    Mar 2009
    Location
    USA
    Posts
    2,717
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    145

    Default

    Quote Originally Posted by ktula View Post
    I have not reverted to the original CommCenter yet. For now, being able to tether is a lot more important than being able to connect to some WiFi networks with no security. I have narrowed the problem down to unprotected WiFi networks. So far, i have no problem connecting to WPA2-protected WiFi networks.
    Is it difficult to revert just to test? Then at least you could nail down what it is and let whoever did the CommCenter patch (are you using dades or the newer one?) know that there's an issue. If it's easy to do, it's worth a shot.
    The preceding forum post has been brought to you by the letter "N" and the number 42.

    iPhone 4, 32GB (iOS 6.1.2 | evasi0n | SHSH: 4.0 - 6.1.2)
    iPad 2 3G, 64GB (iOS 6.1.2 | evasi0n
    |
    SHSH: 4.3 & 4.3.3 - 6.1)

    Restore problems? Read this: http://www.hackint0sh.org/f137/130802.htm

    Did we solve your problem? Got a dollar or two spare? Please Donate!



 

 

Similar Threads

  1. No Wifi, Weird Problem, please read and give advise!
    By besdong_sava in forum PwnageTool
    Replies: 3
    Last Post: 01-21-2010, 05:58 AM
  2. Replies: 2
    Last Post: 04-17-2008, 10:26 AM
  3. Weird Wifi Problem?
    By SimonTuffGuy in forum PwnageTool
    Replies: 1
    Last Post: 04-04-2008, 07:46 PM
  4. Replies: 0
    Last Post: 10-21-2007, 02:09 AM
  5. Weird WiFi problem (not noob)
    By lynzoid in forum General
    Replies: 7
    Last Post: 10-19-2007, 06:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 07:02 PM.
twitter, follow us!