before update my 3GS with fw 4.3.3 to 5.0 "normal update" because my bb will not update it" after see ios 5.0 not have new version for UltraSn0w I downgrade to 4.3.3 again but right now UltraSn0w 1.2.3 not working for me again idk why and still my bb is 6.15.00.i try everything like turn off 3g reinstall bb6.15.00/UltraSn0w but thing help.

any help???

Device: iPhone 3GS