Results 1 to 9 of 9
Discuss Tried to upgrade to 4.3.1, now stuck in DFU mode. Help! at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; Hi I have an iPhone3GS running old bootrom with bb 04.28.06. I was previously on ...
  1. #1
    Newbie Array

    Join Date
    Apr 2011
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default Tried to upgrade to 4.3.1, now stuck in DFU mode. Help!

    Hi

    I have an iPhone3GS running old bootrom with bb 04.28.06. I was previously on ios 4.2.1 and created a custom firmware for 4.3.1 using sn0wbreeze 2.5.

    Unfortunately my phone is stuck in DFU mode (black screen). When I try to restore to any old custom firmware I will get the error 1600. I have used iReb and it will detect that I'm already in DFU mode hence I know its stuck there.

    I've tried using TinyUmbrella to restore to older custom firmware which I have the SHSH to but still no use.

    I've also tried holding power and home button to get out of DFU but once it exits DFU mode it will auto go back into the mode ie. the screen remains black.

    Can anyone help me get my phone back in action. If you need any more info please ask.

    Thanks



  2. #2
    Moderator Array

    Join Date
    Aug 2007
    Posts
    781
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    51

    Default

    Holding both buttons should make you exit DFU into recovery or normal mode, this is weird. What you should try is download redsn0w and select pwned DFU and try restoring.

    If that doesn't work, try fixrecovery from thefirmwareumbrella.blogspot.com
    Last edited by element; 04-07-2011 at 11:48 PM. Reason: added 2nd option

  3. #3
    Newbie Array

    Join Date
    Apr 2011
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    How long should I be holding Power+Home button? I have tried holding it for about 10 secs with phone disconnected from computer and all I get is still the black screen which I assume means I'm still stuck in DFU mode. I have also tried this with phone plugged in and I will hear the "ding" for disconnection and then the sound again which I'm guessing is the reconnection.

    I will give redsn0w a try and see if I get any luck.

    I've tried using fixrecovery as well and unfortunately a lot of gibberish comes up and then after its run all the code, it reverts back to the same state.

    Thanks

  4. #4
    Moderator Array

    Join Date
    Aug 2007
    Posts
    781
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    51

    Default

    You should hold top+home button until you see the apple logo, it takes more than just 10 seconds, I'd say around 40 seconds perhaps. Anyway, redsn0w's pwned DFU option will probably let you restore to a custom firmware without any errors. Let me know how it goes...

  5. #5
    Newbie Array

    Join Date
    Apr 2011
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Cool thanks element, I'll let you know how it goes.


  6. #6
    Newbie Array

    Join Date
    Apr 2011
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Thx element, using redsn0w to install a new custom restore worked thank goodness. Surprisingly I thought redsn0w would update by baseband but it didn't which is all good. But now I've got another problem coming up with iTunes not being able to sync any of my apps back to the iPhone.

  7. #7
    Moderator Array

    Join Date
    Aug 2007
    Posts
    781
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    51

    Default

    hmm what happens when you try to sync? Have you tried manually drag & drop an app to your iphone in iTunes?

  8. #8
    Newbie Array

    Join Date
    Apr 2011
    Posts
    7
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    After more testing it seems that its not the syncing that's the problem but the backup procedure. When I press the x to skip the backing up and straight to the syncing it worked. But when I let it back up, iTunes looks like its running (the circle symbol next to the name of my iPhone on the left bar still spins) but the top bar doesn't move. I've lefted it for over an hr before without it moving. I've also tried it on another laptop but the backing up didn't finish either.

    I've checked the log for the processes and it always hangs at this point in time but don't know what it means. Maybe you can help or direct me somewhere else to look? For safety reasons I've left out the actual info of my computer and replaced with xxx.

    [5252 @ Sun Apr 10 10:53:54 2011] [YSLoader AppleMobileDeviceHelper.exe] tvdumpflags=8
    [5252 @ Sun Apr 10 10:53:54 2011] [YSLoader AppleMobileDeviceHelper.exe] USERDOMAIN=xxx
    [5252 @ Sun Apr 10 10:53:54 2011] [YSLoader AppleMobileDeviceHelper.exe] USERNAME=xxx
    [5252 @ Sun Apr 10 10:53:54 2011] [YSLoader AppleMobileDeviceHelper.exe] USERPROFILE=C:\Users\xxx
    [5252 @ Sun Apr 10 10:53:54 2011] [YSLoader AppleMobileDeviceHelper.exe] windir=C:\Windows
    [5252 @ Sun Apr 10 10:54:14 2011] [YSLoader AppleMobileDeviceHelper.exe]

  9. #9
    Moderator Array

    Join Date
    Aug 2007
    Posts
    781
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    51

    Default

    I don't know what's wrong, but you should try backing up in another computer, if it works on the 2nd computer then the problem is your 1st computer, try reinstalling iTunes and AppleMobileDevice. If it doesn't work, the problem is on the iPhone, and the only fix I can think of is restore and set as a new iphone instead of the backup.

 

 

Similar Threads

  1. iPhone stuck on Safe Mode, won't load up normal mode?
    By CaptainFantastic in forum iPhone 3GS
    Replies: 4
    Last Post: 09-09-2011, 10:02 AM
  2. stuck in dfu mode
    By danitanik in forum iPhone 3G
    Replies: 1
    Last Post: 08-25-2010, 07:34 PM
  3. 3Gs 3.1.2 stuck in DFU mode!
    By jojo80s in forum iPhone 3GS
    Replies: 14
    Last Post: 04-08-2010, 11:51 AM
  4. Replies: 0
    Last Post: 09-29-2009, 06:42 AM
  5. stuck in DFU mode after upgrade to 5A258f
    By bluerockuk1 in forum iPhone "2G" (Rev. 1)
    Replies: 3
    Last Post: 05-07-2008, 09:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 03:41 PM.
twitter, follow us!