Page 1 of 3 123 LastLast
Results 1 to 10 of 22
Discuss Preventing baseband upgrade when loading 4.2.x at the iOS 4.x (iPhone OS 4.x) - Hackint0sh.org; Previously on the iPhone 4 it was possible to use TinyUmbrella to prevent baseband upgrade ...
  1. #1
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default Preventing baseband upgrade when loading 4.2.x

    Previously on the iPhone 4 it was possible to use TinyUmbrella to prevent baseband upgrade when restoring or upgrading iOS 4.x

    The tinyumbrella feature still prevents baseband update but Apple has thrown another barrier in the way.

    Apple have included an extra requirement in the restore logic for iOS 4.2.1 that will prevent the restore from completing if the iPhone baseband is not 3.10.01, this cannot be bypassed with the "exit recovery mode" type solutions previously used

    The two solutions are:

    1. downgrade again to iOS 4.1 or lower (so your baseband doesn't get upgraded).
    2. Wait for an updated pwnagetool that can disable this extra check.


    The current version of ultrasn0w doesn't (yet) unlock 1.59.00 on iOS 4.2.1 anyway, so if you rely on unlock, stay with your currently stable iOS 4 version.

    With this extra requirement, going forward the only viable solution to prevent baseband update is PwnageTool. Apple cannot block pwnagetool so easily.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!



  2. #2
    Newbie Array

    Join Date
    Nov 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default accidentally upgraded to 4.2

    i accidentally upgraded to 4.2 and my base band also got upgraded to 03.10.01. NOW my phone shows a message "No sim card installed" and i can only make emergency calls ....
    Please help (Forget about the jailbreak at least get me out of the "no sim card installed screen" )

    atleast make my iphone work as itouch

  3. #3
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    You can revert back to previous baseband from ios 4.1 while apple is still signing it.
    Download the stock 4.1 firmware and restore it to your iphone4 NOW. Make sure the hosts file is not redirecting apple.gs.com to localhost or to Cydia.
    Do it while you still have time
    ** If you just want to support hackint0sh.org with a donation click here **

  4. #4
    Newbie Array

    Join Date
    Nov 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default still same problem

    downgraded iphone4 to 4.1 from 4.2 ... now the baseband is 02.10.04
    But i am still stuck on the emergency calling screen .it says insert a valid sim to activate.... but i dont have the original sim (actually the phone was used by my brother in UK before sending it to me in India here).

    WHAT could be done now?
    .
    .

  5. #5
    Newbie Array

    Join Date
    Nov 2010
    Posts
    3
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default 1 step up

    Used limera1n and now my iphone 4 is atleast working as an ipod touch ....
    NO emergengy calling ... now the only thing is to unlock it ....
    thanks all


  6. #6
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Please avoid limera1n when you need hacktivation - it has bad hacktivation logic.

    Instead use redsn0w 0.9.6beta4 and run jailbreak with the SIM you want to use inserted.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  7. #7
    Administrator Array

    Join Date
    Oct 2007
    Posts
    4,145
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    10

    Default

    Not at this time to preserve BB on ip4 if you want to go to 4.2.1.
    Plus even if you can, 4.2.1 is a tethered jailbreak.
    Best is to stay at 4.0 - 4.1 at this time
    Current ultrasn0w 1.2 and previous 1.1-1 can unlock 05.19.00.
    ** If you just want to support hackint0sh.org with a donation click here **

  8. #8
    Rookie Array

    Join Date
    Sep 2007
    Posts
    22
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Default

    Quote Originally Posted by varun89yadav View Post
    Used limera1n and now my iphone 4 is atleast working as an ipod touch ....
    NO emergengy calling ... now the only thing is to unlock it ....
    thanks all
    Have u unlocked?

  9. #9
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by varun89yadav View Post
    Used limera1n and now my iphone 4 is atleast working as an ipod touch ....
    NO emergengy calling ... now the only thing is to unlock it ....
    thanks all
    Quote Originally Posted by jokatts View Post
    Have u unlocked?
    There is no unlock for 03.10.01 or 02.10.04 baseband on the iPhone 4 yet.

    It is too late to use Apple's baseband signing system to downgrade to an unlockable baseband. The last time that this was possible was 9 September 2010.

    You might still be able to downgrade from baseband 03.10.01 (the one that shipped with 4.2.1) to 02.10.04 (the one that shipped with 4.1). According to SHSH - The iPhone Wiki Apple is still signing 4.1 restores. This would not offer an unlock, but it might give more chances of a future unlock if for example, the iPhone devteam find an exploit that is only useful in 02.10.04
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!

  10. #10
    Super Moderator Array Olethros's Avatar

    Join Date
    Sep 2007
    Location
    Norway
    Posts
    8,360
    Post Thanks / Like
    Downloads
    0
    Uploads
    0
    Rep Power
    439

    Default

    Quote Originally Posted by thebeej View Post
    I'm currently on iOS 4.1 with baseband 1.59.00 on my iPhone 4. I require ultrasn0w. Is there anyway to upgrade to to 4.2 without updating the baseband? The new ultrasn0w can unlock 1.59.00
    I explained this in the first post, with unsupported and unofficial tools, it is possible but strongly not recommended as you are limited to a tethered jailbreak.

    Wait for updated tools and an untethered jailbreak.
    Please read the stickies & search forum before posting!
    How to report an iTunes restore/update fail in a useful manner
    -

    iPad 3G 64GB (4.3.3, Redsn0w) oldest SHSH 3.2.2
    iPhone 4 32GB (4.2.1, Redsn0w JB-monte) oldest SHSH 4.1
    iPhone 3GS 32GB (4.3.3; Pwnagetool) factory unlocked oldest SHSH 3.1
    iPhone 8GB (3.1.3; Pwnagetool) AT&T Locked - Unlocked with bootneuter

    -
    Did we solve your problem? Got a dollar or two spare ? Donate!


 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 01-25-2012, 10:18 AM
  2. Loading European firmware/baseband into a US iPhone
    By lonniedarko in forum iPhone 4
    Replies: 2
    Last Post: 11-09-2010, 10:11 AM
  3. preventing baseband upgrade
    By iHateMyiPhone888 in forum Spirit (jailbreak)
    Replies: 6
    Last Post: 05-11-2010, 06:44 PM
  4. Replies: 5
    Last Post: 02-08-2009, 10:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin®
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO
(c) 2006-2012 Hackint0sh.org
All times are GMT +2. The time now is 05:46 PM.
twitter, follow us!